Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

NBCNEWS Videos Do Not Play

  • Yes, Opera uses the PPAPI Flash. Chrome recently dropped NPAPI plugin support. So you probably only have three supported plugins - the internal PDF plugin, Flash and the widevine content decryption module.

    Yup, that's what I have...so that clears THAT up, now only to find or just why O38 will not play NBSNEWS videos.

    Onward

  • I checked my plugins and I have three and I have not uninstalled any. Do you know the name of what these other plugins that you had installed were?

  • 3 I opened opera://media-internals/ and got this result under "Players" after reloading the NBCNEWS site and got this::
    "Players
    None"

    That's interesting. If i disable Flash, i got a eternal "loading" spin for that video but if enable Flash then the video plays fine.
    However, if you right click on it you will not see any Flash info.

    Do you have Turbo enabled by chance?

    4 Loaded opera://gpu/ and got this, no clue as to how this affects my problem::

    Only thing I've noticed was the lack of hardware acceleration but i don't know if it could cause the issue.

  • I checked my plugins and I have three and I have not uninstalled any. Do you know the name of what these other plugins that you had installed were?

    Adobe Flash Player
    Version: 22.0.0.209
    Shockwave Flash 22.0 r0

    Chrome PDF Viewer (2 files)

    Widevine Content Decryption Module

  • 3 I opened opera://media-internals/ and got this result under "Players" after reloading the NBCNEWS site and got this::
    "Players
    None"

    That's interesting. If i disable Flash, i got a eternal "loading" spin for that video but if enable Flash then the video plays fine.
    However, if you right click on it you will not see any Flash info.
    Do you have Turbo enabled by chance?

    4 Loaded opera://gpu/ and got this, no clue as to how this affects my problem::

    Only thing I've noticed was the lack of hardware acceleration but i don't know if it could cause the issue.

    #1 Disabling Flash gives me the same screen on NBCNEWS, the initial image from the Video with the Play button in the middle, which does not respond. Enabling Flash does exactly the same thing, as if the image is simply an image (photo) and not an entry point for a video to play. When I hover my mouse over the image, it does change into the familiar "pointing hand" but has no effect.

    #2 Right clicking on the image offers the usual "Save Image, Copy Image, etc" - no indication that it is hovering on top of a video file.

    #3 have no idea how to address "hardware acceleration" - my system uses the Intel Media chip and hardware acceleration cannot be turned off or on.

    Still totally perplexed. This issue has been with me for MANY iterations of Opera Blink, when I try this site using Opera 12.17, I get this::

    There is only the play button on a black image, with the flowing notes above it::

    "NBC News works best with JavaScript turned on

    Sorry, this video needs JavaScript turned on"

    Internet Explorer 11 definitely plays the video.

    I have tried switching the user agent to EVERY possibility, and noting works.

    I REALLY want to find out what is going on, as I cannot watch ANY videos from the NBCNEWS site, and all videos from all other sites I visit work perfectly.

    Any help appreciated.

  • So do you have Turbo enabled by chance?

    3 have no idea how to address "hardware acceleration"

    Settings > Browser.

  • So do you have Turbo enabled by chance?

    3 have no idea how to address "hardware acceleration"

    Settings > Browser.

    Turbo is disabled.

    I have hardware acceleration disabled, but in the interest of searching for a clue, I turned it on and got the same result, no video, clicking on the play button does absolutely nothing, not even anything that would indicate the click was received by their server. it's as if this were a still image.

    I clicked on NBNEWS "Top Videos" on their home page, got here::

    http://www.nbcnews.com/video

    And clicked on a random video::

    http://www.nbcnews.com/news/weather/what-heat-dome-everything-you-need-know-n614176

    Same result, NONE of the NBCNEWS videos play.

  • This one plays fine - in Flash - here. Yours appears to be HTML5 rather than Flash.

  • This one plays fine - in Flash - here. Yours appears to be HTML5 rather than Flash.

    That one also does not play on my system with O 38.0.2220.41, Windows 7.

    Right clicking on it shows it to be interpreted as an image, not a video

    Am I the only one who is having this problem?? All the rest of the folks reading this thread can watch the video??

  • Opera uses the PPAPI Flash

  • Opera uses the PPAPI Flash

    Yes, thank you, the latest Flash PPAPI is installed

  • And clicked on a random video::
    http://www.nbcnews.com/news/weather/what-heat-dome-everything-you-need-know-n614176

    This one played fine here although the commands seem to be missing.

    I have hardware acceleration disabled, but in the interest of searching for a clue, I turned it on and got the same result, no video, clicking on the play button does absolutely nothing

    With hardware acceleration enabled, check opera://gpu again for any suspect message and also try again to check opera://media-internals/ while trying to watch the videos.

    What are your settings for plug-ins in Settings > Websites > Plug-ins?

  • Leo, with hardware acceleration enabled, still says No Players with opera://media-internals/

    in opera://gpu, what would be a "suspect message?"

    I get this under Command Line Arguments::

    "Opera\38.0.2220.41\opera.exe" -noautoupdate --ran-launcher --system-dpi-setting=96 --alt-high-dpi-setting=96 --flag-switches-begin --disable-gesture-requirement-for-media-playback --enable-autofill-ignore-autocomplete-off --with-feature:hi-resolution-thumbnails --with-feature:hidpi-speed-dial-tiles --with-feature:personalized-news-start-page --save-page-as-mhtml --show-autofill-type-predictions --flag-switches-end --disable-direct-npapi-requests --use-turbo2 -- http://www.nbcnews.com/news/weather/what-heat-dome-everything-you-need-know-n614176"

    And these at the tope of the opera://gpu page::

    opera://gpu

    Graphics Feature Status

    Canvas: Hardware accelerated
    Flash: Hardware accelerated
    Flash Stage3D: Hardware accelerated
    Flash Stage3D Baseline profile: Hardware accelerated
    Compositing: Hardware accelerated
    Multiple Raster Threads: Enabled
    Native GpuMemoryBuffers: Software only. Hardware acceleration disabled
    Rasterization: Software only. Hardware acceleration disabled
    Video Decode: Software only, hardware acceleration unavailable
    Video Encode: Hardware accelerated
    WebGL: Hardware accelerated

    Driver Bug Workarounds

    clear_uniforms_before_first_program_use
    disable_d3d11
    disable_direct_composition
    disable_discard_framebuffer
    exit_on_context_lost
    force_cube_complete
    msaa_is_slow
    scalarize_vec_and_mat_constructor_args
    texsubimage_faster_than_teximage

    Problems Detected

    Accelerated video decode interferes with GPU sandbox on older Intel drivers: 180695, 298968, 436968
    Disabled Features: accelerated_video_decode
    Some drivers are unable to reset the D3D device in the GPU process sandbox
    Applied Workarounds: exit_on_context_lost
    TexSubImage is faster for full uploads on ANGLE
    Applied Workarounds: texsubimage_faster_than_teximage
    Clear uniforms before first program use on all platforms: 124764, 349137
    Applied Workarounds: clear_uniforms_before_first_program_use
    Always rewrite vec/mat constructors to be consistent: 398694
    Applied Workarounds: scalarize_vec_and_mat_constructor_args
    Old Intel drivers cannot reliably support D3D11: 363721
    Applied Workarounds: disable_d3d11
    ANGLE crash on glReadPixels from incomplete cube map texture: 518889
    Applied Workarounds: force_cube_complete
    On Intel GPUs MSAA performance is not acceptable for GPU rasterization: 527565
    Applied Workarounds: msaa_is_slow
    Framebuffer discarding can hurt performance on non-tilers: 570897
    Applied Workarounds: disable_discard_framebuffer
    Direct composition flashes black initially on Win <10: 588588
    Applied Workarounds: disable_direct_composition
    Accelerated rasterization has been disabled, either via about:flags or command line.
    Disabled Features: rasterization
    Native GpuMemoryBuffers have been disabled, either via about:flags or command line.
    Disabled Features: native_gpu_memory_buffers

Log in to reply