Certain Videos Do Not Play

  • I have had this problem for awhile through several version of Opera. Opera support essentially ignores me. Youtube videos always work. Videos from mlb.com always work. However, videos on many other sites do not play, such as on MSN. Videos on Twitter and Facebook do not work.

    When I try to play this video I get this error message:

    "We're sorry, an error has occurred when playing video (video format is not supported)."

    http://www.msn.com/en-us/video/animals/brave-ducklings-jump-off-dock-to-follow-mom/vi-BBB37RS

    I can play this video, but I have to click play to run Adobe Flash player.

    http://m.mlb.com/video/topic/11493214/v34563371/must-c-cannon-aviles-doubles-off-gillaspie-at-first

    Version information

    Version: 45.0.2552.812 (PGO) - Opera is up to date
    Update stream: Stable
    System: Windows 7 64-bit

    Thank you for any help!

  • I am unable to replicate it. Both sites play the video just fine. You may want to try resetting your browser’s profile and see if that helps.

  • I reset the profile and have the same problem.

    More information:

    When try to play a video on Google photos, it says, "Invalid parameters."

    On Twitter, videos (unless from Youtube) and animated .gif gives the message, "The media could not be played."

  • I am sorry to hear that, brother. Have you tried following the other suggestions from this post?
    Are you able to replicate it with Google Chrome or another Chromium browser?

    I am out of ideas of what it could be right now.

  • I don't know what's the problem if even happens in a Clean profile but as a workaround, You may uninstall Flash Player, if you don't need it, (those videos works as HTML5 also, as many others).

    If you need Flash for a particular site you may use Flash Player into a portable version of Opera (in a different installation).

  • jimpiersall, you might read this thread, I had a similar problem, solved it with this::

    https://forums.opera.com/topic/17201/video-wiil-not-play-opera-39/36

  • tufuzay,

    Thank you for your help. All videos work fine on Chrome, Firefox, and IE.

    zalex108,

    Thank you as well. Indeed I had the same problem on a clean profile. I tried uninstalling Flash and had the same problem. There was one difference I noticed without Flash. The error message on Google Photos changed to, "This video format is not supported." When I installed Flash again, it went back to "Invalid parameters." It's strange because Google Photos videos look the same as Youtube videos. The MSN video had the same error message both ways.

    bbildman,

    Thanks. I saw that thread when I was searching for solutions. On Opera 45, I can't find the plug-ins in the settings. It appears to be different than what is described in that thread. I tried using Beta for a while, and still had the problem.

  • O.O
    😕 ... :sherlock:

    Perhaps this helps at some point.
    Or maybe in Google.

  • I tried solutions on that "Invalid Parameters" board, and nothing fixed it. I appreciate the suggestions.

  • Take a look at opera://media-internals while trying to play those videos. Also check opera://gpu.

  • This is opera://gpu

    Graphics Feature Status
    Canvas: Software only, hardware acceleration unavailable
    Flash: Software only, hardware acceleration unavailable
    Flash Stage3D: Software only, hardware acceleration unavailable
    Flash Stage3D Baseline profile: Software only, hardware acceleration unavailable
    Compositing: Software only, hardware acceleration unavailable
    Multiple Raster Threads: Unavailable
    Native GpuMemoryBuffers: Software only. Hardware acceleration disabled
    Rasterization: Software only, hardware acceleration unavailable
    Video Decode: Software only, hardware acceleration unavailable
    Video Encode: Software only, hardware acceleration unavailable
    VPx Video Decode: Software only, hardware acceleration unavailable
    WebGL: Unavailable
    WebGL2: Unavailable
    Driver Bug Workarounds
    clear_uniforms_before_first_program_use
    decode_encode_srgb_for_generatemipmap
    disable_direct_composition
    disable_discard_framebuffer
    disable_dxgi_zero_copy_video
    disable_framebuffer_cmaa
    exit_on_context_lost
    msaa_is_slow
    scalarize_vec_and_mat_constructor_args
    Problems Detected
    GPU process was unable to boot: GPU access is disabled in chrome://settings.
    Disabled Features: all
    VPx decoding isn't supported before Windows 10 anniversary update.: 616318
    Disabled Features: accelerated_vpx_decode
    GPU rasterization should only be enabled on NVIDIA and Intel DX11+, and AMD RX-R2 GPUs for now.: 643850
    Disabled Features: gpu_rasterization
    Accelerated VPx decoding is hanging on some videos.: 654111
    Disabled Features: accelerated_vpx_decode
    Some drivers are unable to reset the D3D device in the GPU process sandbox
    Applied Workarounds: exit_on_context_lost
    Clear uniforms before first program use on all platforms: 124764, 349137
    Applied Workarounds: clear_uniforms_before_first_program_use
    Always rewrite vec/mat constructors to be consistent: 398694
    Applied Workarounds: scalarize_vec_and_mat_constructor_args
    On Intel GPUs MSAA performance is not acceptable for GPU rasterization: 527565
    Applied Workarounds: msaa_is_slow
    Framebuffer discarding can hurt performance on non-tilers: 570897
    Applied Workarounds: disable_discard_framebuffer
    Direct composition flashes black initially on Win <10: 588588
    Applied Workarounds: disable_direct_composition
    Zero copy DXGI video hangs on shutdown on Win < 8.1: 621190
    Applied Workarounds: disable_dxgi_zero_copy_video
    Limited enabling of Chromium GL_INTEL_framebuffer_CMAA: 535198
    Applied Workarounds: disable_framebuffer_cmaa
    Disable KHR_blend_equation_advanced until cc shaders are updated: 661715
    Decode and Encode before generateMipmap for srgb format textures on Windows: 634519
    Applied Workarounds: decode_encode_srgb_for_generatemipmap
    Native GpuMemoryBuffers have been disabled, either via about:flags or command line.
    Disabled Features: native_gpu_memory_buffers
    Version Information
    Data exported 5/25/2017, 11:04:12 PM
    Browser version OPR/45.0.2552.812
    Operating system Windows NT 6.1.7601 SP1
    Software rendering list version 12.20
    Driver bug list version 9.36
    ANGLE commit id unknown hash
    2D graphics backend Skia/58
    Command Line Args Files (x86)\Opera\45.0.2552.812\opera.exe" --ran-launcher --opener-id="CKuBiZkgxi9keqd5C:\Windows\explorer.exe" --system-dpi-setting=96 --alt-high-dpi-setting=96 --flag-switches-begin --flag-switches-end --use-turbo2
    Driver Information
    Initialization time 0
    In-process GPU true
    Passthrough Command Decoder false
    Sandboxed false
    GPU0 VENDOR = 0x8086, DEVICE= 0x0166
    Optimus false
    Optimus false
    AMD switchable false
    Desktop compositing Aero Glass
    Diagonal Monitor Size of \.\DISPLAY2 21.5"
    Driver vendor Intel Corporation
    Driver version 9.17.10.2843
    Driver date 8-21-2012
    Pixel shader version
    Vertex shader version
    Max. MSAA samples
    Machine model name
    Machine model version
    GL_VENDOR
    GL_RENDERER
    GL_VERSION
    GL_EXTENSIONS
    Disabled Extensions GL_KHR_blend_equation_advanced GL_KHR_blend_equation_advanced_coherent
    Window system binding vendor
    Window system binding version
    Window system binding extensions
    Direct rendering Yes
    Reset notification strategy 0x0000
    GPU process crash count 0
    Compositor Information
    Tile Update Mode One-copy
    Partial Raster Enabled
    GpuMemoryBuffers Status
    ATC Software only
    ATCIA Software only
    DXT1 Software only
    DXT5 Software only
    ETC1 Software only
    R_8 Software only
    RG_88 Software only
    BGR_565 Software only
    RGBA_4444 Software only
    RGBX_8888 Software only
    RGBA_8888 Software only
    BGRX_8888 Software only
    BGRA_8888 Software only
    YVU_420 Software only
    YUV_420_BIPLANAR Software only
    UYVY_422 Software only
    Diagnostics
    ... loading ...

  • For opera://media-internals:

    For the MSN Video:

    render_id: 51
    player_id: 0
    pipeline_state: kStopped
    event: WEBMEDIAPLAYER_DESTROYED
    url: http://prod-video-cms-amp-microsoft-com.akamaized.net/tenant/amp/entityid/BBB37RS?blobrefkey=103&$blob=1
    total_bytes: 20951724
    streaming: false
    single_origin: true
    passed_cors_access_check: false
    range_header_supported: true
    is_downloading_data: false
    info: MFDemuxer: created video stream, config codec: h264 format: 6 profile: h264 high coded size: [1024,576] visible rect: [0,0,1024,576] natural size: [1024,576] has extra data? false encrypted? false
    audio_channel_layout: STEREO
    audio_codec_name: aac
    audio_sample_format: Float 32-bit
    audio_samples_per_second: 48000
    bitrate: 2905623
    coded_height: 576
    coded_width: 1024
    found_audio_stream: true
    found_video_stream: true
    height: 576
    max_duration: 57.686
    start_time: 0
    video_codec_name: h264
    video_format: PIXEL_FORMAT_NV12
    video_is_encrypted: false
    width: 1024
    audio_dds: false
    platform_pipeline_status_list: 9
    audio_decoder: WMFAudioDecoder
    error: video decoder initialization failed
    pipeline_error: decoder: not supported
    duration: 57.686

    For the Google Photos video:

    render_id: 54
    player_id: 0
    pipeline_state: kStopped
    event: WEBMEDIAPLAYER_CREATED
    url: https://lh3.googleusercontent.com/fYkuoJPCKtwaPtSxmljrVYPkFoDOiYL8NiMZk738wGUUhtfDI-IBYsJ2C3NKxvkKSHetwVpHPlButGoxenXtwpcThdkvrk9wtS-SbLLbdOR-ARzI0ygNJ1ZrtlwA1C2nKlmg57vwNbfkPhAqJIVx2KPnTN-GFU9ijPncGMycl27FKOUIWBKhx_KNDoVbXkPBnDhQzVf-hhCEehd0qdFzDky4GBf1SQ7yquJU6aUrTrF4fz4IO2YVAe8yWZQr8C511H_yanBu6Z5JXj4czgNojnQGNcOiWDKcK23w2bO7NJx-MEd1lNCv0MpQYZFzRwNleHlkHq2QTCgjcFf-fn1k8UPBvegVbW7Ohapo5h9ir8uecRsHChbMrGLrIYb_YFYPTd5SueGGKsfcoj2COeViqG-jEGlph67vFtE4mYe8Zys7axCezsK33L4Xg84sZHMIGiTI-3zBuH5Bf0mWhb91uo96RBUvWWKP5Jl-sJbi1BeKXv1_L_nr-BioX8NEQ3XZile_vZCtCMgkVD1v-a1q4JTjz9jUjAopfudeqMK_9JYZYfVm5-fm9hkXkzd65gnA6ScV9lIY6iAeT2mjdAG5RoruUyruku0W7j1qK5VU4Yow5q4Zzw=m18
    is_downloading_data: true
    total_bytes: 3167265
    streaming: false
    single_origin: false
    passed_cors_access_check: false
    range_header_supported: true
    info: MFDemuxer: created video stream, config codec: h264 format: 6 profile: h264 baseline coded size: [640,360] visible rect: [0,0,640,360] natural size: [640,360] has extra data? false encrypted? false
    audio_channel_layout: STEREO
    audio_codec_name: aac
    audio_sample_format: Float 32-bit
    audio_samples_per_second: 44100
    bitrate: 737824
    coded_height: 360
    coded_width: 640
    found_audio_stream: true
    found_video_stream: true
    height: 360
    max_duration: 34.341666
    start_time: 0
    video_codec_name: h264
    video_format: PIXEL_FORMAT_NV12
    video_is_encrypted: false
    width: 640
    audio_dds: false
    platform_pipeline_status_list: 9
    audio_decoder: WMFAudioDecoder
    error: video decoder initialization failed
    pipeline_error: decoder: not supported
    duration: 34.341666

    For the Twitter video:

    render_id: 60
    player_id: 1
    pipeline_state: kStopped
    event: WEBMEDIAPLAYER_CREATED
    url: https://video.twimg.com/tweet_video/C6BGkfUUYAAulCb.mp4
    total_bytes: 216755
    streaming: false
    single_origin: true
    passed_cors_access_check: false
    range_header_supported: true
    is_downloading_data: true
    info: MFDemuxer: created video stream, config codec: h264 format: 6 profile: h264 baseline coded size: [600,336] visible rect: [0,0,600,336] natural size: [600,336] has extra data? false encrypted? false
    bitrate: 340007
    coded_height: 336
    coded_width: 600
    found_audio_stream: false
    found_video_stream: true
    height: 336
    max_duration: 5.1
    start_time: 0
    video_codec_name: h264
    video_format: PIXEL_FORMAT_NV12
    video_is_encrypted: false
    width: 600
    error: video decoder initialization failed
    pipeline_error: decoder: not supported
    duration: 5.1

  • Sorry, I don't know what any of this stuff means, so if someone feels like looking at it, there it is.

  • Try enabling hardware acceleration.

  • leocg,

    I enabled it and restarted the browser as directed. It did not fix the problem. I sincerely appreciate your suggestion though.

  • I found a difference between my chrome://gpu and opera://gpu

    Chrome: Rasterization: Hardware accelerated

    Opera: Rasterization: Software only. Hardware acceleration disabled

    I also noticed a lot of differences in the media internals between Chrome and Opera:

    The opera log had this line: 00:00:03 165 error video decoder initialization failed

    Here they are for comparison:

    CHROME:

    Player Properties
    Property Value
    audio_buffering_state BUFFERING_HAVE_ENOUGH
    audio_channels_count 2
    audio_codec_name aac
    audio_dds false
    audio_decoder FFmpegAudioDecoder
    audio_sample_format Float 32-bit planar
    audio_samples_per_second 48000
    bitrate 2905623
    duration 57.719
    event PAUSE
    found_audio_stream true
    found_video_stream true
    height 576
    info FFmpegDemuxer: created audio stream, config codec: aac bytes_per_channel: 4 channel_layout: 3 samples_per_second: 48000 sample_format: 6 bytes_per_frame: 8 seek_preroll: 0ms codec_delay: 0 has extra data? true encrypted? false
    is_downloading_data false
    max_duration 57.719
    passed_cors_access_check false
    pipeline_buffering_state BUFFERING_HAVE_ENOUGH
    pipeline_state kSuspended
    player_id 0
    range_header_supported true
    render_id 12
    single_origin true
    start_time 0.033
    streaming false
    time_base 1/30000
    total_bytes 20951724
    url http://prod-video-cms-amp-microsoft-com.akamaized.net/tenant/amp/entityid/BBB37RS?blobrefkey=103&$blob=1
    video_buffering_state BUFFERING_HAVE_ENOUGH
    video_codec_name h264
    video_dds false
    video_decoder FFmpegVideoDecoder
    video_format PIXEL_FORMAT_YV12
    video_is_encrypted false
    width 1024
    Log
    property filter

    Timestamp Property Value
    00:00:00 00 pipeline_state kCreated
    00:00:00 00 event WEBMEDIAPLAYER_CREATED
    00:00:00 00 url http://prod-video-cms-amp-microsoft-com.akamaized.net/tenant/amp/entityid/BBB37RS?blobrefkey=103&$blob=1
    00:00:00 281 total_bytes 20951724
    00:00:00 281 streaming false
    00:00:00 281 single_origin true
    00:00:00 281 passed_cors_access_check false
    00:00:00 281 range_header_supported true
    00:00:00 286 pipeline_state kStarting
    00:00:00 295 info FFmpegDemuxer: created video stream, config codec: h264 format: 2 profile: h264 high coded size: [1024,576] visible rect: [0,0,1024,576] natural size: [1024,576] has extra data? true encrypted? false
    00:00:00 295 info FFmpegDemuxer: created audio stream, config codec: aac bytes_per_channel: 4 channel_layout: 3 samples_per_second: 48000 sample_format: 6 bytes_per_frame: 8 seek_preroll: 0ms codec_delay: 0 has extra data? true encrypted? false
    00:00:00 295 audio_channels_count 2
    00:00:00 295 audio_codec_name aac
    00:00:00 295 audio_sample_format Float 32-bit planar
    00:00:00 295 audio_samples_per_second 48000
    00:00:00 295 bitrate 2905623
    00:00:00 295 found_audio_stream true
    00:00:00 295 found_video_stream true
    00:00:00 295 height 576
    00:00:00 295 max_duration 57.719
    00:00:00 295 start_time 0.033
    00:00:00 295 time_base 1/30000
    00:00:00 295 video_codec_name h264
    00:00:00 295 video_format PIXEL_FORMAT_YV12
    00:00:00 295 video_is_encrypted false
    00:00:00 295 width 1024
    00:00:00 298 audio_dds false
    00:00:00 298 audio_decoder FFmpegAudioDecoder
    00:00:00 300 video_dds false
    00:00:00 300 video_decoder FFmpegVideoDecoder
    00:00:00 300 pipeline_state kPlaying
    00:00:00 332 video_buffering_state BUFFERING_HAVE_ENOUGH
    00:00:00 333 audio_buffering_state BUFFERING_HAVE_ENOUGH
    00:00:00 333 pipeline_buffering_state BUFFERING_HAVE_ENOUGH
    00:00:00 334 event PLAY
    00:00:00 295 duration 57.719
    00:00:08 139 event PAUSE
    00:00:08 141 pipeline_state kSeeking
    00:00:08 141 audio_buffering_state BUFFERING_HAVE_NOTHING
    00:00:08 144 video_buffering_state BUFFERING_HAVE_NOTHING
    00:00:08 144 pipeline_state kPlaying
    00:00:08 246 video_buffering_state BUFFERING_HAVE_ENOUGH
    00:00:08 248 audio_buffering_state BUFFERING_HAVE_ENOUGH
    00:00:08 248 pipeline_buffering_state BUFFERING_HAVE_ENOUGH
    00:00:08 251 event PLAY
    00:00:08 626 event PAUSE
    00:00:08 626 pipeline_state kSeeking
    00:00:08 626 audio_buffering_state BUFFERING_HAVE_NOTHING
    00:00:08 626 video_buffering_state BUFFERING_HAVE_NOTHING
    00:00:08 626 pipeline_state kPlaying
    00:00:08 645 video_buffering_state BUFFERING_HAVE_ENOUGH
    00:00:08 649 audio_buffering_state BUFFERING_HAVE_ENOUGH
    00:00:08 649 pipeline_buffering_state BUFFERING_HAVE_ENOUGH
    00:00:08 722 event PLAY
    00:00:09 173 event PAUSE
    00:00:09 174 pipeline_state kSeeking
    00:00:09 174 audio_buffering_state BUFFERING_HAVE_NOTHING
    00:00:09 175 video_buffering_state BUFFERING_HAVE_NOTHING
    00:00:09 175 pipeline_state kPlaying
    00:00:09 258 event PLAY
    00:00:09 529 video_buffering_state BUFFERING_HAVE_ENOUGH
    00:00:09 533 audio_buffering_state BUFFERING_HAVE_ENOUGH
    00:00:09 533 pipeline_buffering_state BUFFERING_HAVE_ENOUGH
    00:00:21 450 event PAUSE
    00:00:37 116 pipeline_state kSuspending
    00:00:37 120 pipeline_state kSuspended

    OPERA:

    Player Properties

    Property Value
    audio_channel_layout STEREO
    audio_codec_name aac
    audio_dds false
    audio_decoder WMFAudioDecoder
    audio_sample_format Float 32-bit
    audio_samples_per_second 48000
    bitrate 2905623
    coded_height 576
    coded_width 1024
    duration 57.686
    error video decoder initialization failed
    event WEBMEDIAPLAYER_DESTROYED
    found_audio_stream true
    found_video_stream true
    height 576
    info MFDemuxer: created video stream, config codec: h264 format: 6 profile: h264 high coded size: [1024,576] visible rect: [0,0,1024,576] natural size: [1024,576] has extra data? false encrypted? false
    is_downloading_data false
    max_duration 57.686
    passed_cors_access_check false
    pipeline_error decoder: not supported
    pipeline_state kStopped
    platform_pipeline_status_list 9
    player_id 0
    range_header_supported true
    render_id 52
    single_origin true
    start_time 0
    streaming false
    total_bytes 20951724
    url http://prod-video-cms-amp-microsoft-com.akamaized.net/tenant/amp/entityid/BBB37RS?blobrefkey=103&$blob=1
    video_codec_name h264
    video_format PIXEL_FORMAT_NV12
    video_is_encrypted false
    width 1024
    Log
    property filter

    Timestamp Property Value
    00:00:00 00 pipeline_state kCreated
    00:00:00 00 event WEBMEDIAPLAYER_CREATED
    00:00:00 270 url http://prod-video-cms-amp-microsoft-com.akamaized.net/tenant/amp/entityid/BBB37RS?blobrefkey=103&$blob=1
    00:00:00 874 total_bytes 20951724
    00:00:00 874 streaming false
    00:00:00 874 single_origin true
    00:00:00 874 passed_cors_access_check false
    00:00:00 874 range_header_supported true
    00:00:01 00 pipeline_state kStarting
    00:00:03 162 info MFDemuxer: created audio stream, config codec: aac bytes_per_channel: 4 channel_layout: 3 samples_per_second: 48000 sample_format: 4 bytes_per_frame: 8 seek_preroll: 0ms codec_delay: 0 has extra data? true encrypted? false
    00:00:03 162 info MFDemuxer: created video stream, config codec: h264 format: 6 profile: h264 high coded size: [1024,576] visible rect: [0,0,1024,576] natural size: [1024,576] has extra data? false encrypted? false
    00:00:03 163 audio_channel_layout STEREO
    00:00:03 163 audio_codec_name aac
    00:00:03 163 audio_sample_format Float 32-bit
    00:00:03 163 audio_samples_per_second 48000
    00:00:03 163 bitrate 2905623
    00:00:03 163 coded_height 576
    00:00:03 163 coded_width 1024
    00:00:03 163 found_audio_stream true
    00:00:03 163 found_video_stream true
    00:00:03 163 height 576
    00:00:03 163 max_duration 57.686
    00:00:03 163 start_time 0
    00:00:03 163 video_codec_name h264
    00:00:03 163 video_format PIXEL_FORMAT_NV12
    00:00:03 163 video_is_encrypted false
    00:00:03 163 width 1024
    00:00:03 165 audio_dds false
    00:00:03 165 platform_pipeline_status_list 9
    00:00:03 165 audio_decoder WMFAudioDecoder
    00:00:03 165 error video decoder initialization failed
    00:00:03 195 pipeline_error decoder: not supported
    00:00:03 196 pipeline_state kStopping
    00:00:03 196 pipeline_state kStopped
    00:00:03 509 event WEBMEDIAPLAYER_DESTROYED
    00:00:03 163 duration 57.686

  • I found a difference between my chrome://gpu and opera://gpu
    Chrome: Rasterization: Hardware accelerated
    Opera: Rasterization: Software only. Hardware acceleration disabled

    It shouldn't make any difference on video playing.

    I enabled it and restarted the browser as directed. It did not fix the problem

    And does opera://gpu shows that video decode uses hardware acceleration? Also, any error message under "Log Messages'?

  • Here are the lines on video.

    GRAPHICS FEATURE STATUS:
    Video Decode: Hardware accelerated
    Video Encode: Hardware accelerated
    VPx Video Decode: Software only, hardware acceleration unavailable

    PROBLEMS DETECTED:
    VPx decoding isn't supported before Windows 10 anniversary update.: 616318
    Disabled Features: accelerated_vpx_decode
    Accelerated VPx decoding is hanging on some videos.: 654111
    Disabled Features: accelerated_vpx_decode
    Zero copy DXGI video hangs on shutdown on Win < 8.1: 621190
    Applied Workarounds: disable_dxgi_zero_copy_video

    DRIVER BUG WORKAROUNDS
    disable_dxgi_zero_copy_video

    LOG MESSAGES:
    GpuProcessHostUIShim: The GPU process exited normally. Everything is okay.

  • Here are the lines on video.

    It seems OK.

  • Okay. Thank you for looking it over.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.