Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Skipping acquire of configured file ... architecture 'armhf'

  • I am attempting to install the Opera Browser on my Raspberry Pi that seems to perform well in general. The default browser is pretty good, but I use Opera on my other systems and would like to get it firing on all cylinders in my Linux learning process.

    I tried an install directly from the Opera site, but that failed with little detail as to what the problem was.

    Error: "A Package could not be found that allows the action to complete. More information is available in the detailed report."
    Unfortunately, I looked high and low, but could not find the detailed report anywhere.

    Then I tried using instructions from:

    https://www.linuxbabe.com/browser/install-opera-debian-ubuntu-linux-mint-free-vpn

    I get down to the next to last command and get this architecture related message and I can't quite find anything on why this fails.

    Error Message:

    pi@raspberrypi:~ $ sudo apt update
    
    Hit:1 http://archive.raspberrypi.org/debian stretch InRelease
    Hit:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease      
    Hit:3 https://deb.opera.com/opera-stable stable InRelease             
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    331 packages can be upgraded. Run 'apt list --upgradable' to see them.
    
    **N: Skipping acquire of configured file 'non-free/binary-armhf/Packages' as 
    repository 'https://deb.opera.com/opera-stable stable InRelease' doesn't support architecture 'armhf'**
    
    

    The error sounds like I am totally in the wrong dimension ... but I am a Linux nube well under the necessary pay grade.

    Can anyone suggest what the failure is about/what I should do next ... or another route that might actually work to get this installed?

    Thanks!
    B

  • @bcavender The Opera repo is configured for Intel architectures - either 32-bit i386 or 64-bit AMD64, there are no ARM builds on that server.

  • @sgunhouse

    Yep, wrong dimension was the right guess.

    Looks like there is zero interest in whipping one up for the ARM as well based on a little digging on that specific issue.

    Nuts, I hosed on this one!

    But thank you for the assist.

    I greatly appreciate the help!!!

    B