Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera Shortcut Key - Delete History

  • Same with me. I just noticed this the other day and also found out that [Ctrl]+[Shift]+[End] (etc) no longer works in any text editor, word document, VS Code environment.

    When I reboot all works again until I open Opera (v63.0.3368.71) and attempt [Ctrl]+[Shift]+[Del] again, which messes up my Windows keyboard shortcuts. 😞

  • @wphaskett Ah ha! The disabling of [Ctrl]+[Shift]+... keys in windows only occurs while Opera is open. Close Opera and the Windows (3rd party apps) shortcut keys work again. Still would like to press [Ctrl]+[Shift]+[Del] to clear browsing history though.

  • Hi. So I have attempted to log this as a bug but the online bug wizard thing is dreadful and just times out.

    When Opera is open, some keyboard shortcuts do not work. For certain CTRL + SHIFT + END/HOME does nothing, as opposed to selecting all text from the caret to the end, or beginning of the document.

    This effects ALL applications on the host machine.

    Closing Opera mitigates the issue

    Repro Steps:

    1. Open Opera (version 63.0.3368.71)
    2. In another application, say Notepad++, attempt to select a large volume of text using this super handy keyboard shortcut

    Expected Result:
    this keyboard shortcut functions as it has for the last 20 years

    Actual Result:
    Nothing happens.

    Mitigation:
    Close Opera - the shortcut works.

  • It's a known bug. No need to file on it. For a workaround, see https://forums.opera.com/topic/34954/opera-shortcut-key-delete-history.

  • Thanks, @johnd78

  • @johnd78 Thank you so much John! I use 5 different browsers (Chrome, IE, Firefox, Edge and Opera) for my work due to the nature of different system we need to login. I need to clear the history many times in a day to clear the cache. This issue has caused me to go into the settings in all browser which was a pain until I found your solution. I just had to kill the Video Handler extension in the Opera Task Manager twice as you mentioned and Boom! I was able to use the shortcut on all browser all day as I never closed Opera. You made my day!

  • johnd78:
    Would you mind letting me know where the profile directory is with the JSON file that needs to be edited?
    Typing about://about as URL in Opera, it should be in C:\Users\xxx\AppData\Roaming\Opera Software\Opera Stable, but there is no profile directory and no JSON file in that location that looks like the one you are editing.
    Thank you!

  • @limpemu That's the profile directory.
    And the Preferences file has no extension.

  • @leocg
    Thank you, found it! So glad my keyboard is working normally again!!!

  • @johnd78 said in Opera Shortcut Key - Delete History:

    Quick solution: If you do not need the "Pop-up window with video" function, you can close the "Extension: Video handler" process in the Opera task manager. (You will have to close it 2 times). The problem "Ctrl + Shift + Del" will disappear. Valid until browser restart.

    Possible solution for experienced users only! : Close Opera browser. Using JSONedit, delete the section "extensions" - "commands" in the Preferences file in the profile. Clipboard04.jpg
    Save changes.

    After that, you can use the keyboard shortcuts "Ctrl + Shift +" in third-party programs when Opera is running and "Ctrl + Shift + Del" to delete the history in the current Opera 63 Stable.

    Actually, you just need a text editor (Notepad ++ preferred), and find the block "command" and delete everything inside it (keep the "{}"). I searched for "ctrl+shift+page" and found the hotkey inside that block.

  • @youngexplorer said in Opera Shortcut Key - Delete History:

    Actually, you just need a text editor (Notepad ++ preferred)

    Yeah, that's the way it works, too. It's just more convenient for me to use JSONedit

    Now there is no "Ctrl+Shift+" problem on the clean profile, the developers fixed it, but only for the clean profile. For the old profile you need to edit the Preferences file.

  • @johnd78 said in Opera Shortcut Key - Delete History:

    @youngexplorer said in Opera Shortcut Key - Delete History:

    Actually, you just need a text editor (Notepad ++ preferred)

    Yeah, that's the way it works, too. It's just more convenient for me to use JSONedit

    Now there is no "Ctrl+Shift+" problem on the clean profile, the developers fixed it, but only for the clean profile. For the old profile you need to edit the Preferences file.

    Thanks for the info. It drove me crazy, I used so many ctrl+shift+etc. I spent so much time just figure out that Opera is the problem. Spent quite sometime to get to the solution too.

  • @youngexplorer

    Thanks for the tip. I had a look at the file, and decided to replace every instance of

    "global":true
    

    with

    "global":false
    

    That seems to have worked as well, and I would presume this approach lets any formerly global hotkeys remain operational within Opera.

  • @aonsaithya Good spot. Seems to be easier and get to the core of the problem.

  • So, there is no actual solution even in Opera 64? Still doesn't work

  • @hakuteiken said in Opera Shortcut Key - Delete History:

    So, there is no actual solution even in Opera 64? Still doesn't work

    ctrl + shift + del works fine in Opera 64 now as long as you're not using a profile that had the problem. If you are, you'll have to fix your Preferences file as mentioned earlier.

  • @hakuteiken The simple solution I read somewhere else was to navigate to Settings they search for "reset". Then select "Restore settings to their original defaults". Since I use Opera, but not as my primary browser, I didn't have a problem with this. It solved the problem for me.

  • @hakuteiken There are some solutions was discussed here that are effective. Editing the preference file should take about 5-10 minutes to implement if you willing to get your hand dirty. I think there are other considerations from the developer team because it's quite a simple fix.

  • on v. 65.0.3467.42 the same problem. Deleting the content of the commands{} part did not help.
    Resetting the browser did help, but lost all passwords for logins.

  • @dlenen said in Opera Shortcut Key - Delete History:

    Deleting the content of the commands{} part did not help.

    The method of deleting the "commands" section should have helped. Are you sure you deleted correctly? Step-by-step instructions from @burnout426.

Log in to reply