Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Back button skips a page

  • @hucker If some users have that problem, i don't really think that is "random" Maybe bug, or something else.

  • @panosv have been trying to reproduce it, but didn't encounter it even single time. Could you describe your steps exactly? Every little detail could be crucial here. What I've been doing:

    1. Have 'Peter Hucker' in clipboard
    2. Open new tab
    3. Ctrl+V (paste clipboard into address bar)
    4. Press Enter
    5. Click on link (imdb search result)
    6. Wait for page to load
    7. Press Back button
      That's what I've been doing and each time I have landed on google search result page. Mind that this was done on clean profile.

    Do you have any extensions installed? Any settings changed?

  • Do you actually wait for the page to finish loading, or do you press Back when the page is still loading? Do you actually use the Back button in the address bar, or is this a back button on your mouse? (Some mice allow you to reconfigure the buttons, but if the setting is something other than "System default" I have heard of that resulting in multiple actions sometimes.)

  • Try uninstalling and reinstalling again. I have tried to recreate your problem and found mine to be dandy.

  • I now can't reproduce it anymore. I tried waiting for the page to load, and not waiting for the page to load, and it works perfectly. Seems completely random. The mouse is not reconfigured apart from programming the middle button to delete (within the normal basic logitech driver - it's just a plain optical wheelmouse). I go back by clicking the back button. I've not changed much apart from:

    Removing most of the keyboard shortcuts as I find Opera doing all sorts of stuff when I think I'm typing (note to programmers, please do not have single key shortcuts!!!)

    Installing "Adblock" (not plus), "Adblocker for Youtube", and Opera's own "blocks ads" option.

  • Single-key shortcuts are optional, if you don't enable "Advanced keyboard shortcuts" then you don't encounter them.

  • @sgunhouse said in Back button skips a page:

    Single-key shortcuts are optional, if you don't enable "Advanced keyboard shortcuts" then you don't encounter them.

    Not in my experience, although I may be thinking more of M2. All hell has broken loose while I think I'm typing an email, and I've never turned on any such thing.

  • @mgeffro With imdb, it's same as you. Same result. No skip. I can't write when and how it's happening. Yes, i have some extentions, not all enabled at the same time. but i don't know if any of them is the "problem", because it's happening 1 per days or 2 per hour. I can't tell you what is the problem, i had ithe problem 2 or 3 days before.

  • This post is deleted!
  • Tracking this internally as https://bugs.opera.com/browse/DNA-73425. We seem to had some success with reproducing itwith network bandwith 50kb/s. Also we managed to reproduce it on chromium (using different UA string there than default) and we already have logged there probably related issue https://bugs.chromium.org/p/chromium/issues/detail?id=898134

  • You need to do something, because back button skips a page, and sometimes, back button is grey and can't go to previous one.. 2 months sence the last report and nothing change, i don't know why.

    I say all above, because i see that you keep updating Opera in Opera blog.

  • I have been getting this for a long time as well. It seems to happen when I click on the search result within a second or so, waiting longer usually prevents it from happening. I thought it might be related to pending XHRs but it doesn't seem to be the case--even when there are pending ones but I wait longer, the issue doesn't occur.

  • The same thing, I don't use the actual back button not the keyboard shortcut. Instead, I have a mouse button mapped to the "system's" back function (through Logitech's Gaming Software). It often happens when I open a new tab (Ctrl + T, sometimes through the mouse, sometimes through the keyboard) enter a random search term and quickly follow a result link. If I want to go back Opera skips the search page and instead goes directly to the New Tab screen, going forward returns me to the clicked link, not the search results page. Essentially as if I had gone from the new tab directly to the clicked link, no search in between.

  • @mbartelsmanm said in Back button skips a page:

    "system's" back function (through Logitech's Gaming Software).

    Can you map it specifically to alt + left arrow to see if it makes any difference?

  • @burnout426 have the same problem and alt + left arrow still skips the search page

  • @burnout426 issue continues

  • @mgeffro said in Back button skips a page:

    We seem to had some success with reproducing itwith network bandwith 50kb/s.

    I still couldn't reproduce with 50kb/s throttling and cache disabled in the developer tools.

    @mbartelsmanm said in Back button skips a page:

    @burnout426 issue continues

    Can you change the shortcut to do an ESC (for stop loading) first and then back to see if it works around the issue? It seems it has to do with navigation to a link and then using back when the pages haven't finished loading. Are you on a slow connection? Do you have any extensions installed? Some extensions make take a bit to analyze the pages where it triggers the bug easier.

  • @burnout426 tried a few things, it seems to happen if you click a link before the search page finishes loading, but only if the search is the first thing you do in a new tab.

    That is:

    • open new tab
    • enter query in address bar
    • perform search
    • before results finish loading click a link
    • press back/alt-leftarrow
    • skip a page back to new tab
  • @mbartelsmanm said in Back button skips a page:

    That is:

    Yep. That's what I was trying. Couldn't reproduce myself, but definitely believe you.

  • it's still happening, is there any fix with new opera? thanks.

Log in to reply