Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

How to disable extremely irritating CTRL + wheel zooming

  • Problem: When doing scrolling in pages with touchpad, and switching between pages with CTRL + TAB, then "CTRL+wheel" zooming is constantly triggered.

    This behavior is extremely irritating since it's happening constantly. Would think that UI engineers in Chrome/Opera would have noticed such simple failure case in mouse + keyboard operation. However, so far I have failed to find solution. Simply blaming "it's OS issue" is NOT solution.

    Factually I don't ever intentionally try to do "CTRL + wheel" zooming in web browser, so I would really desire to be able disable this inconvenient behavior.

    I've tried some "No MouseWheel Zoom" addon, but it fails with "touchpad scroll + "CTRL+TAB" combo, still triggering undesired zooming.

    okey, factually case is "CTRL + touchpad scroll", but I believe in most touchpads that is from app point of view same as "CTRL + wheel".

    [Mod note: Topic posted in wrong forum moved to more appropriate one]

  • Under Settings > Browser > Shortcuts, you might try disabling one or both of the "gesture" settings. Mind you, in old versions of Opera it wouldn't help, so no guarantee it will in current versions - but that's all I can suggest. (Properly, "mouse gestures" are right button drag actions, while "rocker gestures" involve quickly pressing one button then another, and hence neither actually covers the scroll+modifier key case; but that is the best I can suggest.)

  • @sgunhouse Well I did that but it still does that zooms on mouse gestures. In my case on double click. It's a real pain.

  • Rather irritating that this blatant bug is not getting fixed. Behaviour is really irritating. It certainly does not help that Opera's employees are trying to disregard problem as "system problem", while it's not.

    Please, please, just add configuration option to allow turning this off.

  • @kikonen It's not a bug. You can request a way to disable the shortcut in the proper forum.

  • how about an about:config, like in FF.. This was extremely useful when configuring for specifics.. There are other reasons I don't use FF... This was one of their strong points.. Too bad Opera as long as it's been around hasn't integrated such a good idea in configuration into their own yet..

  • If you use X, you could use block-scroll-mod-x11 to prevent unintended zooming system-wide.

    Browser only solution would be Disable Scroll Wheel Zoom Chrome extension. I suppose you could use Install Chrome Extensions extension to use the Chrome extension in Opera. You might need to modify the extension, if your browser uses other key than Ctrl for zooming, see here.

  • @jarnos personally I need solution working on win/lin/osx. Regarding that plugin, I recall trying it, and irritatingly it does not work in all cases, when switching between tabs fast

  • @kikonen Yes, the extension is not perfect; there seems to be race condition.

  • @jarnos Actually I just realized plugin what I had earlier tried was likely "No Mouse Wheel Zoom", thus older plugin doing same thing. Need to give change for this new plugin to see how it works.

    And yes, sometimes this one also hits same race conditions.

    I.e.

    1. Start scrolling page with wheel (our touchpad)
    2. Change page with CTRL + TAB
      => sometimes random zooming is hit, amount depends how fast page was scrolling at step (1)
  • It helps if you have a way to monitor scrolling events and a way to disable the problematic pointer device temporarily. I do not know how you do it in Windows and macOS. Even in Wayland it seems to be impossible to disable only a pointer device, if the device is pointer & keyboard combo. But in X11 it can be handled well.

Log in to reply