How to turn zooming with the trackpad off

  • Is there a way to turn zooming with the trackpad off? I rather just zoom with command-(plus) and command-(minus), and as you can read below, the zooming with trackpad badly interferes with how I use my browser (must be a bad habit I picked up while using Firefox :) )

    Bug report: scrolling with trackpad unintentionally zooms

    Summary:

    Due to how zoom and scroll are implemented on Mac OS, a scroll may unintentionally turn into a zoom. This happens many times a day for me. I like to turn this behaviour off.

    Just a few observations:

    • In Opera, scrolling is achieved by moving two fingers up or down on a trackpad. I think this is generic Mac OS behaviour (it works in all applications)
    • In Opera, scrolling is achieved by moving two fingers up or down on a trackpad while simultaneous holding down the option/alt key. I think this is Opera-specific behaviour (it does not work in other applications).
    • This problem is reproduced on Mac OS 10.10.5 with Opera 42.0.2393.94, with mouse gestures and advanced keyboard shortcuts turned OFF.

    Steps to reproduce:

    • Use two finger on a trackpad on a Mac to scroll up ro down on a lengthy page.
    • Observe that once you release your fingers, the scrolling continues for a few moments until it slows down and stops. This is gerneric Mac OS behaviour (it works in all applications)
    • During those moments, press down the option/alt key

    Expected behaviour:
    I would have expected that the scrolling would come to a stop, regardless of my keypress.

    Actual behaviour:
    As soon as I press the option/alt key =, the “residual” scroll movement aborts and is turned into a zoom behaviour.

    The above happens a LOT to me. I seem to have a habit of opening a few tabs, scroll through the page, quickly navigate two another tab using command—option-arrow shortcut.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.