Google as search intrusive engine

  • Because of its excellent UI I am still using Opera 12, just because I do not like what came after that.

    I have the search engine field in the address bar and use Startpage as the default search engine. That worked very well until lately; every time I nowadays start up Opera, there is the addition of Google to the search engine list, set again as default engine. I tried to be smart and pointed the Google name to Startpage, but the did not help; this got the keyword o while the new one gets g and points to Google again. It does this every time I restart or open a new window in Opera

    De- and re-installing Opera does not change anything. This indicates that it is not Opera itself, but something that interferes on its start up. Virus checks are negative. In the task manager I do not see anything suspicious, but that is not really a wonder with the svchost possibility to hide behind.

    It is unnecessary to say that I dislike Google because of its snooping and I distrust the later versions of Opera for the same reason, its engine.

    Anyone any idea?

  • You have checked for malware and adware?

  • IIRC this is by design and have been there since a long time. Opera will always revert to Google or whatever is the default pre-defined search engine if you try to set another one (except for the ones pre-installed) as the default search engine.

    Don't remember if there is any workaround for this.

  • Thanks for the comments. Forgot to tell: although the direction of the new Google search engine entry seems to be complete (? am not completely sure, have to check in detail), pressing enter after giving in the search word or clicking on the new Google entry in the drop-down selection does not do anything at all. The other searchers in the drop-down do work with clicking.

    sgunhouse: Yes, nothing. I use for that the combination of extended hosts file, Privatefirewall, ghostery and the privacy settings of Opera. On some pages, e.g. banking, this is so repressive that I don't see what I want/need to.

    leocg: Until a few weeks ago I never had that in this constellation. The version 12 in Linux still goes in the good old way and in the other machines (3, Win and Linux too) this does not neither happen.

    I, or better: we, because this is a business computer with various itinerant users, may be petty users, but searching is used quite a lot on this machine and it is extremely annoying to have to grab the mouse each time and not just press enter. Keyboarding still is a lot more efficient and faster than mousing through menus and old habits don't die silently :-)

  • Using an outdated browser for business?
    Having messed with it a lot. Is it that you use outdated system(s) perhaps? Old hardware? Just asking - having suspicions.

  • joshi: The slowest one is a year old and runs a Core2 quad @ 2.4, the fastest run C2quad @ 3. Win7, Opensuse 13.1. However, we don't see the causal connection between hardware and what is an obvious software error that did pop up unexpectedly. There must have been introduced something, although after some bad experiences we are hell-bent on security.

    Yes, Opera 12 is very outdated and some sites we must run on an other one, but it is by far the best and most flexibly configurable one. I have heard that we are not the only ones with that opinion. It is such a pity that Opera chose to change to a copy of some mediocrity, but, as it costs quite some money to make a browser that then is distributed for free, it is understandable.

  • Don't remember if there is any workaround for this.

    O'RLY?

    @zerealbigboss : What is your (fully detailed) Opera version ?

  • At this moment 12.16.1860, the 32-bit version. normally V12.17/64-bit. Same effect in both, though. I did not try a lower version yet. As said, it happens just on this intensively used machine and under Win7, which because of some necessary Win-based programs is run on this one more than Suse, so I suspect some outside interference. The ultimate solution is, of course, re-installing drive C:, but for the justification of that effort the annoyance is just too small.

  • All of our head-scratching did not point in any direction, although the problem must have been caused by some action of one of us, unwittingly combining a few unique factors.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.