Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera completely freezes itself and a windows 7

  • Hi,

    I'm a new Opera user but conversant with a wide range of browsers - none of them freeze my system.

    When it happens I can't acess task manager, the only recourse is to physically power down and boot again.

    Note: This freezing does not occur with Opera GX.

    I've tried fresh installs of latest Opera stable, beta and developer. + an earlier stable version from April. They all freeze

    It is not an addon, customisation or windows 7 issue. It has even happened on first loading of a new install when I first opened settings.

    I use a dedicated uninstaller before reinstalling again

    Aside from that - as if this wasn't enough - freezing mainly occurs after I have left Opera doing nothing for 10 minutes or more.
    It is not site specific and not to do with number of tabs open, I rarely use more than one or two.

    As an experiment I tried a tab autoloader to refresh a simple text web page every couple of minutes while I went away for a break and Opera still froze everything.

    cpu and ram usage are normal for these types of browsers.

    I'd like to sort this because Opera otherwise works very well
    and loads pages faster than most on my system.

  • @lindencoll Sounds like the computer may be trying to go to sleep, but something is preventing it from doing so properly. I'd suggest you try one of those little mouse mover utilities that fake moving the mouse to prevent the computer from sleeping and see what happens then.

  • @lindencoll Have you looked in the Windows system Event Logs for anything odd occurring at/just before each freeze occurrance time? Sometimes there may be clues there...

  • @sgunhouse

    Thank you,
    I'll try both.

  • It's not a sleep issue I checked with cmd

    It's not an event issue - I just shopped on Amazon for ages, went away for 20 minutes, returned and Opera froze. Nothing registered in events until I rebooted.

    "A request to disable the Desktop Window Manager was made by process (Opera web browser)"

    But checking back after booting that looks to be standard

    But, as | said other browsers don't freeze.

  • @lindencoll
    Two independent ideas to check:

    1. disable Opera battery saver
    2. disable graphic hardware acceleration in Opera
  • @donq

    I disabled battery saver before last freeze.

    I'll try next with acceleration disabled

  • Still freezes everything.

    Pity GX is so dark/garish - that's working fine.

  • LindenColl, do you use the uBlock Origin extension ?

    I was having similar problems a few weeks ago with Opera freezing after around 10 minutes of inactivity. I couldn't identify the cause.

    But when an unrelated problem developed which I could pinpoint to uBlock Origin, I reinstalled that extension and I have not had the freezing issue since.

  • Thanks, but it freezes with or without ublock.

    Looks like it could be a sleep issue after all - tab snooze!

    I dsabled this option, browsed for a while, left three tabs open, then took a long break for a meal and this time no freeze upon resumption.

    For a moment it looked like it was going to hang as a menu took a tad too long to close, but then all fine.

    I'll see how it goes.

  • No go - it froze everything again after the next break.

  • @lindencoll The option to disable tab snoozing seems to not be working.

    For now try going to opera://discards and un-check the option for auto discardable for the tabs.

  • Thanks.

    I see an auto-discardable option, so unchecked that.

  • @lindencoll Thanks, fixed the previous reply.

  • Sadly, it didn't work - everything still freezes.

    I notice it says chrome://discards/, in fact the chrome:// prefix can be substituted for opera - chrome://flags etc

    Looking like I'll have to enable retain tabs and remember to shut down before taking any breaks.

  • @lindencoll So maybe the problem wasn't with tab snoozing.

  • @leocg
    A logical conclusion,

    EspeciaIly as I just checked Chromium Ungoogled discards which has auto tab discarding enabled and doesn't freeze.

    Opera is lighter and faster on my system though, hence my looking for options to rectify this freezing.

  • But, one last try in this vein (which could also be useful in other ways)

    I decided to check up on Chrome instead of Opera.

    "The new solution to current tabs freezing during idle or sleep is to change the Chrome flag for occlusion from Default to Disabled. Hopefully that helps anyone else having this issue."

    Opera has the same flag.

  • Only solution thus far is to remember to close Opera when I take a break from the pc, or brave the garish darkness of GX. 🔦

    Mouse movers don't prevent the big freeze.

  • @sgunhouse said in Opera completely freezes itself and a windows 7:

    @lindencoll Sounds like the computer may be trying to go to sleep, but something is preventing it from doing so properly.

    Finally sussed it.

    I got fed up and after disabling both sleep and hibernation it doesn't freeze itself or the system.

    Not too clever a solution tho'.