Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Mouse buttons not working properly

  • I am using Logitech MX Anywhere 3 mouse.
    There seems to be issues with back and forward buttons:

    1. Back button seems to be working fine in all but one case. When googling and clicking on a search result, upon clicking Back, it skips Google results page and goes straight to speed dial page. Happens every time. Don't think this skip happens in any other case.

    2. Forward button does not work at all with default settings, currently I am using workaround for it (changed button function using Logitech Options software from function Forward to assigned keystroke Ctrl+Right), but even that works only 30-50% of the time. After some time it stops working, but a random click with a mouse anywhere on screen seems to repair it and the button can be used again.
      Also Forward button similarly skips google results page, when clicked on speed dial page it goes straight to the page opened from results.

    39294cdc-b3ec-412f-a716-cdf27217f49b-image.png

    Tried reinstalling Opera, that didn't solve anything. This is happening for a while, but my current version is 74.0.3911.160

  • @iwua I'm using a 20 € Rapoo mouse and don't have this issue.

  • @mathias87 that doesn't exactly solve anything for me

  • @iwua But it helps you by saying that the problem doesn't happen with that mouse model/brand.

    By the way, I've checked here with my Microsoft mouse and both back and forward buttons are working.

  • @iwua

    1 ) As far as I know it's by design when you use the address bar/start page search and will happen no matter how you go back.
    If you open Google and search from there, the back button should lead you back to the results page

  • @leocg Usually you need to set the mouse to something like "System default", I'm not even using the Logitech software with my M590 trackball and it works fine that way.

  • @leocg not sure how do you mean that, if I use address bar search, open a google result and then click on back button in opera browser - not using mouse, it goes back fine to the results - the same for forward
    d79a3dc3-05aa-47dd-89f0-2925f892c1af-image.png

  • @iwua i use the MX Master3 and the MxMaster2 before that, and always has existed the same problem - the mouse-forward button - at its system default setting - does not work from the speed dial page.. so f'n annoying
    so, its not just a matter of "it works for me and i'm a forum-cop, so there is no problem and we're just gonna ignore you for 2 month", it goes beyond that one persons issue.

    Untitled.png

  • @shaneyshane @iwua
    I'm on a Razer Deathadder Elite and the problem exists for me as well. I've only recently switched back to Opera so there may be settings I'm unaware of but googling has been anything but helpful.
    I've found that if I place the cursor in the address field then forward click MAY work - i.e. sometimes the first time, sometimes the third time - also on the Speed Dial page. But it's not a satisfactory solution as it is easier simply to click on the browser 'Forward' button.