Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera adding bookmarks to speed dial all the time

  • Yeah, I haven't had ANY issues with Opera and I was using it since v7, as I recall.

  • I think I may have found the culprit and now the speed dial has not refreshed with this spam!

    I actually checked and found that I had the same pages that kept on being added to the speed dial bookmarked! They were added there by Opera, not me.

    After I deleted them from bookmark I no longer have the speed dial pages added again! Will update if they come back, however for now seems like all's working fine!

  • @suguru999

    I have not a single bookmark saved on my system, and I am on Windows 7 (32-bit), but booking.com has been re-added twice within 24 hours, as descriped here and here.

    Since I run Opera in a sandbox usually so that my original (portable) installation remains untouched I would be able to reproduce these unexpected re-addings within a certain time frame (= as long as I do not run Opera unsandboxed).

    Please let me know if you wish more information.

    @moderators: Sometimes I wish some threads referring to the same topic would be merged. Right now I am afraid I could be accused of doing some sort of cross-posting here.

  • Did you not install the latest update?

    Though mind you, a version with no bookmarks at all might be another story. I'm npt sure they considered that ...

    As always, when you delete something make sure to go to Bookmarks and empty the trash.

  • @sgunhouse

    Did you not install the latest update?

    I installed the update (unsandboxed), but I should have a backup from before that update.

    Though mind you, a version with no bookmarks at all might be another story. I'm npt sure they considered that ...

    Yes, and also I am on Windows 7, not on Windows 10...

    As always, when you delete something make sure to go to Bookmarks and empty the trash.

    I will do so. Thank you again for your support.

    EDIT:
    Maybe I should mention that I don't have any bookmark saved, but I use fifteen speed dial entries (no pre-installed ones among them).

  • @yanta Yeah, it just re-added themselves again ಠ~ಠ and I thought it fixed the issue... Meh...

  • @suguru999 Are you on Windows 10, or are you on Windows 7 (like me)?

    I think the best we can do is to provide further information on our settings, but probably we should wait until we are told what information the developers need exactly.

  • I'm on Windows 10, issue came up after one of the updates from M$

  • @suguru999 said in Opera adding bookmarks to speed dial all the time:

    I'm on Windows 10, issue came up after one of the updates from M$

    That's a known problem that Opera is working on.

  • Just a bit of an update. We are currently working on fixing this from two different angles. As we now know cause for current issue we try to play it safe. It's going a bit slow as we gradually introduce changes in code and monitor results with releases.

  • @mgeffro Appreciate the update! I will stay with Opera till the end!

  • @mgeffro

    Only in case feedback is helpful on this matter:

    Today Opera has been idle on my computer for some hours. When I returned to my PC I noticed a new speed dial entry (Reserved) being added.

    • Windows 7 32-bit
    • Opera 54.0.2952.64 (Update stream: Stable), portable installation
    • Opera's built-in VPN being enabled
    • Opera's user interface language = English (United states)
    • Preferred languages for webpages = English (United States) and English
    • Use a prediction service to help complete searches and URLs typed in the address bar = unticked
    • Predict network actions to improve page load performance = unticked.
    • The bookmark's trash folder was empty.
    • No use of Opera's synchronization service.
  • @yanta this was expected push from us. We recently added feature to opt-out for this promoted content if it disturbs you. To do so:

    • Make sure flag opera://flags/#partner-bookmarks-opt-out is enabled
    • Go to opera:settings
    • Disable 'Receive promoted Speed Dials and Bookmarks'

    Please note that it's currently enabled in developer only and should make it's way to stable with v56 (or sooner when we confirm there are no unintended regressions with it).

  • @mgeffro Thank you very much for your kind reply.

    this was expected push from us.

    FWIW: I hadn't mentioned that the region of my operating system is set to "German (Germany)", so the German subpage was selected correctly for that push (I wrote only that Opera's "Preferred languages for webpages" is set to "English (United States)".

    We recently added feature to opt-out for this promoted content

    That is excellent news. Thank you very much to you and the Opera developer team for allowing this option!

  • @mgeffro said in Opera adding bookmarks to speed dial all the time:

    • Make sure flag opera://flags/#partner-bookmarks-opt-out is enabled
    • Go to opera:settings
    • Disable 'Receive promoted Speed Dials and Bookmarks'

    As of Opera 57.0, the description seems to switch the meaning of Enable/Disable:

    Partner bookmarks opt-out option

    Option which allows opting-out from receiving new partner bookmarks. – Mac, Windows, Linux

    But the default is [E], meaning everyone is opted out by default which seems impossible to me... is the wording of this option switched around to the opposite of the actual setting?

  • The flag is to enable the option in settings to opt-out from the promoted speed dials.

  • @dtgq Yes, I see that here now.

    settings>startpage>Receive promoted Speed Dials and Bookmarks

    The meaning of settings switch is reversed now in latest dev v59 on Win10, so it seems.
    It was switched on; There were no promo bookmarks on speed dial.
    I switched off and the promo bookmarks on speed dial came in.
    chrome://flags/#partner-bookmarks-opt-out is still Default [E]

  • @s390g2
    57.0.3082.0 prerelease was proper, on debian 9x.