Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera takes 3 seconds to initially load, but everything else is super fast. Can't figure out! Help, please!

  • Hello everyone!

    I should let you know that I have one of the fastest PCs, with a new gen Core i7 8700K, 32GB of blazing RAM, M.2 SSDs, and so forth.

    Internet Explorer, Firefox, and Edge load up within a fraction of a second upon launch.

    Opera has this annoying three-second pause. It's super annoying!

    Once it's loaded, if I open a new instance (Control-N), a new window opens immediately. New tab? Immediately. Drag a tab to the desktop? Immediate!

    But when I load up the first instance via a Windows Shortcut, or by clicking on a link.. there is the darn pause again!

    I'm running 52.0.2871.40.

    I tried removing my three extensions; uninstalling the app entirely; renaming my configuration folder; even creating a brand new user in Windows; re-installing it... and still... that dreaded pause upon loading!

    It seems to be really tasking the CPU, as my mouse pointer even lags during those 3 seconds.

    Any ideas would really be welcome!

    Because of this, I begrudgingly set my default browser to Firefox, something I did not want to do.

    What exactly can be causing this lag/CPU utilization when a new instance is opened from a shortcut or even directly from launcher.exe?

    Again, every other app; brower or otherwise, is super fast, and hitting "Control-N" to open a new window is also at the speed of light.

    Any insight would be most appreciated! I just can't figure it out! Thank you!!!

  • @lawguy
    Three seconds! I'm sure a lot of people would be delighted if anything loaded that quickly! 😃
    Seriously, have you tried Chrome? I'm not being facetious, but it could be a Chromium thing, and all Chromium-based browsers might have that lag. Edge and IE are always going to load fast, as they are optimised in the operating system, bing Microsoft products. If Chrome also has the lag, that could be the reason for the loading delay.
    🙂

  • @lawguy
    Some 3rd party antivirus / security suite? (if yes, turn it off for testing)
    Autoupdate? (you can rename/delete autoupdater somewhere in opera folders)
    Proxy detection? (you can disable that in windows internet options, lan settings)

  • Hi guys!

    Thanks so much for the replies!

    Yup... three seconds. Brutal! Amazing how spoiled we are, eh? Believe me, my first modem was a 300 baud one with a physical switch for Answer/Originate.

    I spent a tiny fortune on this rig - so yeah, three seconds is a lot! Heck, it was enough to make Firefox my default browser.

    Great suggestions, above.

    I didn't think of downloading Chrome. I'll give it a shot.

    No third-party antivirus apps here - just the default one that came with Win10 Pro.

    I'll check out the proxy and autoupdate settings tomorrow, and report back.

    I'm sure this didn't happen when I first set up the computer. Report to follow! Thanks again!

  • Hi again!

    Turned off Proxy detection and Removed Auto Update.. Still slow!

    Installed Chrome, and interestingly, it, too has a slight delay upon launch... about 1.5 seconds.

    Again, Firefox; Edge; IE... all instantaneous. Control-N for a new instance of Opera.. Instantaneous.

    Chrome did have a bit of delay, but certainly not the 3 or 4 seconds that Opera takes to load.

    Interestingly, I noticed that when I close Opera, my mouse pointer has an hourglass alongside it for the same length of time - about three seconds - as when I load the app.

    Something is happening upon launch and upon exit.

    It's really a shame, because I truly love everything else about Opera. I'd sure love to figure this out!

  • @lawguy
    The hourglass for a brief period after you close Opera's window is almost certainly it writing its data to the hard drive before actually shutting down. If you look in the Windows Task Manager processes list, I suspect you will see that the program doesn't actually shut down as soon as you close the window, which is very common behaviour by many programs.
    🙂

  • @lawguy
    Weird. I have got PC at about a half of your spec (M2 SSD is present however), Opera starts (with about 10 enabled extensions and 20 tabs) in 1-2 seconds (this may correspond to your chrome engine delay). IE is instant, but it is set to display empty screen. No firefox or chrome here to test.

    Well, I have disabled news and removed everything other from new tab screen - but this should not affect Opera startup very much.

    Then I have disabled opera sitecheck (in hosts file) - but this should not affect startup time either - or does? (You can use Fiddler to analyze Opera startup traffic.)

    Then I have sync disabled.

    In advanced settings I have "Delay loading of background tabs" checked, other options do not seem likely to affect startup speed.

    In opera://flags (experiments) I have Simple cache for HTTP enabled - although I do not recall any startup time difference with default cache either.

    Of course I have tweaked Windows itself to behave more like W95/XP, but this affects overall impression and not specific applications. Cortana, onedrive and some other background resource hogs are disabled or removed.

    Then my screen is old-fashioned 19" - but again, this should help games (if I played them) - but not Opera startup.

    No more ideas at the moment.

  • Thanks, donq, for the suggestions, I am going to try them.
    And yes, Dave, I do understand that programs will write to the hard drive; delete temp files; etc, upon closing, but to see an hourglass for three seconds... I have no other app that does that.

    And as for my SSD, again, we are talking about a Samsung 960 PRO 2TB M.2 chip right on the motherboard.

    Windows 10 takes literally 9 seconds to boot up on my system. Opera takes a third of that time! 😉

    I do have six very large, high-res monitors attached to the system, powered by two EVGA GeForce 1080ti FTW cards. Wonder if multi-monitor support affects anything.

    Now, I just noticed something interesting...

    I just opened Operate and looked at the Task Manager. Is this normal behaviour?

    One tab opens at start... Just the screen with the Speed Dials and a Google search box.

    Is it normal to see so many subprocesses like that?

    Thanks!
    0_1523669018502_2018-04-13_21-18-18.jpg image url)

  • @lawguy the opera 52.0.2871.40 u r run 'n is 64 bit..

    New update Stable 52.0.2871.64 now..

  • @lawguy said in Opera takes 3 seconds to initially load, but everything else is super fast. Can't figure out! Help, please!:

    Windows 10 takes literally 9 seconds to boot up on my system. Opera takes a third of that time! 😉

    My W10 takes 5-6 seconds to boot. Literally. Yet again, half spec cause half time 😉 Well, I have no external video card, this may change things.
    I know one image processing program, which uses GPU and does run about four times faster, if one in graphic card properties sets priority to programs, not to games. Sorry I don't know how exact settings are named.

    Is it normal to see so many subprocesses like that?

    Thanks!
    0_1523669018502_2018-04-13_21-18-18.jpg image url)

    I would say that many sub-processes are okay, but why are there console host, command processor and this 1Password thingie? On my system, there are only opera browser sub-processes. If you disable your extensions, do these strange entries vanish? Just wondering.

    And I'm using 32bit Opera.

  • 1Password is an extension.

  • Guys! I solved it!
    Opera officially loads up in about a quarter of a second now!

    Here's the scoop:
    I have two EVGA GeForce 1080TI FTW graphics cards, each running three monitors.

    I tried disabling one of my cards, and it was blazing fast! I also tried booting in Safe Mode, and again - it was super fast!

    I tried all sorts of adjustments... SLI... Display spanning... I even removed my SLI bridge between both cards. All to no avail The minute I enabled all six monitors - there was my 3-second lag again.

    I uninstalled the nvidia drivers. This gave me one screen of course, and five blank ones.

    I then wanted to try again, so I went to device manager and Scanned for Changes.

    All six monitors lit up again... and.......... I clicked on Opera....... and...

    The program literally loaded the split second (nanosecond?!) I clicked my mouse. Amazing.

    Thank you all so much for all the suggestions! I can't believe it's solved. It seems like other apps are snappier, too.

    Thanks guys!

  • @lawguy
    Good news, glad you solved it!
    I guess there must have been something in the graphics driver installation that was causing the lag, which reinstalling it has fixed. That could have potentially caused a delay with other programs as well as Opera of course.
    🙂

  • Topic closed as solved. If in up until to a month the author needs the thread to be reopened, just report it. briefly explaining the reason.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.