[Solved] How to make opera to ignore windows DPI

  • I want to show real pixels on opera on my HDPI screen with windows configured at 125%, I only want to do this sometimes so I'm looking for a command line or an option.

    Chrome can accept these parameters: /high-dpi-support=1 /force-device-scale-factor=1
    Firefox can be configured on about:config -> set layout.css.devPixelsPerPx to 1

    Any idea how to do this with opera?
    Thanks

  • Starting Opera with '--alt-high-dpi-setting=' used to work.

  • @leocg This kinda works but I don't understand how it is calculated, I had to use 77 so it would kinda match the size of the other browsers. Everything is blurry (including i.e. 1 pixel borders). Isn't there just a way to enable the options like chrome have them?

    Even IE and Edge can easily be set to 100% and there are no blurry lines there and the sizes match exactly (for most elements).

  • Isn't there just a way to enable the options like chrome have them?

    Opera accepts some Chromium command lines, maybe you can try those you mentioned.

    This kinda works but I don't understand how it is calculated, I had to use 77 so it would kinda match the size of the other browsers

    For a 100% DPI you should use 96.

  • Isn't there just a way to enable the options like chrome have them?

    Opera accepts some Chromium command lines, maybe you can try those you mentioned.

    I tried them before posting, same behavior as without them.

    This kinda works but I don't understand how it is calculated, I had to use 77 so it would kinda match the size of the other browsers

    For a 100% DPI you should use 96.

    The calculation seems to be inverted I dunno, maybe 77 kinda matched the size because my windows scaling is 125%, so 96 / 1.25 = 76.8, 96 does nothing and 120(96 * 1.25) just makes it bigger. I also tried 76.8 I think it just doesn't consider decimals

    Also it wouldn't be ideal for me but I tried setting opera zoom to 80% to compensate (1 / 1.25 = 0.8), text and 1 pixel borders are still blurry

  • The calculation seems to be inverted I dunno, maybe 77 kinda matched the size because my windows scaling is 125%, so 96 / 1.25 = 76.8, 96 does nothing and 120(96 * 1.25) just makes it bigger. I also tried 76.8 I think it just doesn't consider decimals

    To match 125% DPI the number seems to be 120.

  • Also it wouldn't be ideal for me but I tried setting opera zoom to 80% to compensate (1 / 1.25 = 0.8), text and 1 pixel borders are still blurry

    Maybe one thing is not related to the other?

  • Starting Opera with '--alt-high-dpi-setting=' used to work.

    For a 100% DPI you should use 96.

    This is the solution I actually wanted but opera misbehaved before because I didn't restart after changing windows scaling, after a windows restart opera is now not showing blurry stuff and the size is correct.

    Thanks

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.