Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

No Tab cycling (Ctrl+Tab) in Opera 30

  • In Opera 30.0.1835.59 tab cycling (Ctrl+Tab / Ctrl+Shift+Tab) doesn't work anymore. In Opera 29 it worked fine. Any ideas?

    Thanks a lot.

  • Go to settings and reset keyboard shortcuts.

  • Worked. Bingo. Thx!

  • Is there a way for Ctrl-Tab to cycle through the tabs themselves instead of displaying that "preview", like Opera 29 did? I couldn't find anything in the options. I already removed the "most recently used order" option, but I still don't like the new behavior.

  • Currently that is done by the 1 and 2 keys. They cycle forward and back through your tabs. If you want ctrl+tab to do that just reassign the keys.

  • Hi @alobpreis: please have a look here 😉

  • Thanks a lot @l33t4opera and @lando242 (BTW, you missed the CTRL in those shortcuts). 🙂

  • Is there a way to force Opera to add new tabs always on the far right (next to + icon) instead always on the right of currently active tab? This is so annoying. I would also love to have a feature from Opera 12 - minimize tab after clickin on it (to easily switch to previously active tab).

    I will be thankful for any tips.

  • Is there a way to remove that annoying preview while I'm cycling through the tabs? 😞

  • @alobpreis
    You can add the control in there if you want. Just replace the 1 or the 2, whichever you want.

    @fr4ntic
    I use the extension Classic Tabs. Very handy.

    @brunoabatti
    Settings > Show Tab Previews > uncheck it.

  • @lando242 It's not the hover on tab preview, it's the ctrl+tab or ctrl+shift+tab preview.

  • Hi @brunoabatti, go to opera:settings/configureCommands, and remove the default key bindings for "Cycle backward through tabs" / "Cycle forward through tabs", or rebind them to e.g. "Ctrl+F1" / "Ctrl+F2", and then scroll down to the "Switch left through tabs" / "Switch right through tabs", and add "Ctrl+Shift+Tab" / "Ctrl+Tab" for these functions, or try to use the default shortcuts: "Ctrl+PageUp" / "Ctrl+PageDown", or "Ctrl+1" / "Ctrl+2" 😉

  • @brunoabatti Interesting. I don't have a preview when I cycle tabs using either Ctrl+Tab or the 1 or 2 keys...

  • @lando242 - do you have tab button enabled? I have tab previwes disabled, tab button enabled - and when I switch tabs with Ctrl+Tab and do not perform that quickly, then after third a second or so tab menu appears and these f***ing preview windows pop up either. How I hate these preview windows ... 😞

  • I don't see a tab button option. I have tab menu enabled though.

  • Tab button, tab menu - it's the same, I think. Anyway, when you're surfing in tab menu, don't you see previews? If not, then I wonder, what setting controls this behavior - I haven't found it yet.

  • When I press Ctrl+Tab in changes me to the next tab immediately. No preview. If I hold down Ctrl+Tab it cycles threw all of my open tabs.

  • Hi @brunoabatti, go to opera:settings/configureCommands, and remove the default key bindings for "Cycle backward through tabs" / "Cycle forward through tabs", or rebind them to e.g. "Ctrl+F1" / "Ctrl+F2", and then scroll down to the "Switch left through tabs" / "Switch right through tabs", and add "Ctrl+Shift+Tab" / "Ctrl+Tab" for these functions, or try to use the default shortcuts: "Ctrl+PageUp" / "Ctrl+PageDown", or "Ctrl+1" / "Ctrl+2" 😉

    That's not what he's asking. He's asking to disable the preview while using the MRU tab function. Rebinding the keys to move left/right doesn't accomplish the same thing.

    There is a checkbox for enabling/disabling the tab preview, but as of right now it doesn't seem to be correctly applied during tab switching.