Finally, "Auto-sync data" option in phone settings causes Opera running in background. Unchecking that, issue's gone. Phone Settings > Accounts => tap on the three dots (upper right) and uncheck Auto-sync data: Of course, Opera Startup option should be set to "Continue where I left off". Opera Settings > Startup => "Continue where I left off" Setting above two options, Opera stays closed after "Force Stop" till next time I'll use it. @sgunhouse Topic solved. Thanks for your help!