Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

No complete control of Opera

  • @sgunhouse Yes, I have notifications disabled.
    I always exit Opera via its own menu, clearing also History etc. There is no difference.

    There is no way for Opera to stay closed. If I "Force Stop" it, it reopens itself within an hour and then tries to connect to Opera server every 6-8 hours.

    Thanks for reply!

    Here's my Settings:
    0_1543912250860_Settings.png

  • Must not have read your own settings there. Under Startup it says "Open a new tab after 2 hours of inactivity". Change that.

  • @sgunhouse I'll try and report back... THANK YOU!!!

  • Come to think of it, probably reading that wrong. It probably means "If you haven't used Opera in 2 hours, then forget what was open (go to a new tab instead of continuing). But it does sound strange regardless.

  • @sgunhouse We'll see. Also "Force Stop" must be stronger than Setting you've mentioned so I don't think this is the issue. We'll see...

  • Just a clarification... When I say, "If I "Force Stop" it, it reopens itself...", I mean in background. You cannot see it running, unless you go to device Settings > Apps => Opera and see that "FORCE STOP" button is active again.

  • @sgunhouse said in No complete control of Opera:

    Must not have read your own settings there. Under Startup it says "Open a new tab after 2 hours of inactivity". Change that.

    I'd read that many times but I've never thought that it can affect Opera, even after exiting...which is not normal (imo).

    Changing that Startup option seems to work, till now...
    Almost 3 hours since "Force Stop" has been applied and Opera stays closed. In a few hours, I'll be sure about it.

  • @werby said in No complete control of Opera:

    Changing that Startup option seems to work, till now...
    Almost 3 hours since "Force Stop" has been applied and Opera stays closed. In a few hours, I'll be sure about it.

    @sgunhouse
    UNFORTUNATELY, right after my last post, Opera opened itself again trying to connect to...

    What I've done:
    Startup option had been set to "Continue where I left off". After that, I "Force Stop" Opera, then I rebooted my phone and checked if "Force Stop" button was still inactive. It was. After almost 3.30 hours Opera came to active and tried to connect to.

    As I've suspected, nothing has changed. It seems that an Opera internal timer causes this issue which is really very annoying, at least for me.

    I hope for a fixing...

    Thanks for your attention!

  • @sgunhouse So, the initial question remains:

    Why should my/our phone be forced to send & receive...something to/from an Opera server, every 6-8 hours and why should always Opera (is forced to) run in background?

  • Finally, "Auto-sync data" option in phone settings causes Opera running in background. Unchecking that, issue's gone.

    Phone Settings > Accounts => tap on the three dots (upper right) and uncheck Auto-sync data:
    0_1544239499429_Accounts.png 0_1544239517015_Accounts1.png

    Of course, Opera Startup option should be set to "Continue where I left off".

    Opera Settings > Startup => "Continue where I left off"
    0_1544240538372_Startup.png 0_1544240552736_Startup1.png

    Setting above two options, Opera stays closed after "Force Stop" till next time I'll use it.

    @sgunhouse Topic solved. Thanks for your help!

Log in to reply