Tab Menu and Account Menu Offset

  • I am currently using Opera for Mac. I have noticed in the past few versions that when the window is at full size (or at least against the right edge of the screen), the drop-down menus for the tab menu and the account menu are pushed too far to the left. They appear to be about 20-30 pixels off.

    It seems that they are trying to force themselves to have a margin to the right and that margin, when against the edge of the screen, causes the triangle at the top to be misaligned. Of course, this isn't a huge issue, but as someone who loves Opera and wants to encourage others to use it, it is a small thing that makes the browser look second-tier … which it is definitely not!

    Here is a screenshot: http://postimg.org/image/kh0o61m9h/

    Anyone else seeing this?

  • This issue seems to still be present even in the newest Opera Beta for Mac, which has the new UI.

  • Hi @thatchrismiller! This is actually not due to Opera, but due to the way OS X positions these popups (they're NSPopovers, by the way). You can see the same in Safari's Download popup if you just position the window close to the screen edge (screenshot for your enjoyment: http://imgur.com/FMborzU ).

    At this moment the only 'solution' we know of is making the buttons wider or adding space to the right: this would not prevent the popover from moving if it's close to the screen edge, but could help when the window is maximized.

    But we think the cure would be worse than the disease: the effect on the toolbar look is profound, it looks much worse than a popover that's positioned slightly to the left to prevent it going off-screen. Our best hope is Apple fixing the mechanism in OS X so that even though the popover is shifted, the arrow keeps pointing to the requested origin. Fingers crossed 🙂

  • @avi… Thank you so much for the explanation. I was thinking it probably had to be something like this. Opera doesn't seem like the type of developers to overlook something like this. Now, I guess I should head over to the Apple message boards and complain there. 🙂

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.