Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

[Closed by Request]New Opera developer 29

  • Would be really nice if you could bring back the old Opera functionality of panning large images by pressing the spacebar.
    Using the scroolbars is really awkward in comparison.

  • New Opera developer 29.0.1785.0, the change log, and the announcement 😉

    "Today’s developer build includes a update to our mouse gestures, adding back three useful gestures that trigger when clicking links.

    • Open link in a new tab (Down),

    • Open link in a new window (Shift + Down),

    • Open link in a new background tab (Ctrl + Down or Down + Up),

    In case you aren’t familiar with mouse gestures, they work by holding the right mouse button, moving the mouse a certain direction, then letting go of the button.

    To help new users to find out more about mouse gestures, Opera now shows a sliding toolbar when performing a gesture for the first time. It explains that a gesture was detected and links to a help page documenting all the others.

    If you feel there are other gestures that are missing, please let us know. We make no promises that we will implement all the suggestions but we are always interested in what can help you navigate faster."

    Small notice: if the "opera:flags#trees-in-bookmarks" flag is enabled, the content of the BM page is empty, as well as the drop-down list of the folders in the BM pop-up.

    One of interesting changes IMHO: opera:flags#customizable-key-bindings (disabled by default), if you enable it, you can find it in Settings > Shortcuts > Configure Shortcuts:

    Slight notice: in my case, I had to first press the "Reset All" button, to make it work.

    ☕ \m/ :cheers:

  • After automatic updating Opera from 27 to 29 the icons images in the start page are disappeared and instead thumbnails scatches reappeared. (sorry for my english)

    How me return to the previous form (witch experimental start page in Opera developer 27)?

    It appears they completely ditched off favicon-styled 'experimental' start page since v27. Such a pity...

  • New Opera developer 29.0.1788.0, the change log, and the announcement 😉

    "We have added a new way to view your open tabs, accessible via the start page. Simply click on the entry which is currently titled “Activity”. From there you, each of your synced devices will be listed. Now, click on any device name to see its list of open tabs."

    Known issues

    • Crash on opening the identity (sync login) dialog

    • The share dialog cannot be easily dismissed

    • Using the tabs (activity) page in a private window crashes the browser

    One of new flags is the "opera:flags#tab-menu-with-recent-tabs" (disabled by default), which enables tab menu which gives another view of all opened tabs in the current window in addition to recently closed tabs, and tabs synced from other devices (it requires the Settings > User interface > "Enable tab menu" option to be enabled).

    ☕ \m/ :cheers:

  • With Opera 29.0.1788.0 print preview doesn't work any more. Just hanging. Printing without preview (cntl+shift+P) works.
    Problem didn't occur with previous release.

  • Question: Is there a way to start opera with all extensions disabled? Would be useful for problem determination.

  • Hi @hasi68: yes, you can, you need to add the "--disable-extensions" command line switch at the end of the shortcut, which you use to launch the Opera, as follows:

    On Windows: "\path\to\launcher.exe" --disable-extensions

    On Linux: /path/to/opera-develper --disable-extensions

    In case, that you want to check also, whether one of the flags is the culprit or not, you can add the "--no-experiments" switch, as shown below:

    On Windows: "\path\to\launcher.exe" --no-experiments

    On Linux: /path/to/opera-develper --no-experiments

    Small note: you can use both of the above switches at once, just make sure to add a space between them.

  • Hi @l33t4opera: Thanks a lot for your useful tips. I solved the problem with the print preview already. It was my fault, i disabled the internal chrome pdf viewer plugin because I'm using the pdf extension, but the print preview needs the internal pdf viewer.

  • With the latest developer version, I am seeing some (but not all) HTML selects not rendering correctly or rendering as empty.


  • +1, discretely hinting to this topic

  • New Opera developer 29.0.1794.0, the change log, and the announcement 😉

    ☕ \m/ :cheers:

  • 29.0.1794.0 doesn’t work at all for me. I can open Opera, but no pages, not even speed dial, settings, about, etc. All I get is ”Slut på minne” (Out of memory). Reinstalled with Synaptic, restarted the system. No difference. Two Opera-processes are active: opera-developer and its gpu-process. Ubuntu 14.10 64-bit, 7,5 GiB RAM.

  • Completely uninstalled and installed again, no difference.

    joakim@JoWa:~$ opera-developer
    [0306/] Trying to restart the zygote/sandbox multiple times in quick succession. Something is probably very wrong, we will will give up.
    [0306/] Invalid url pattern: opera://print/*
    [0306/] Failed to launch child process
    [0306/] Failed to launch child process
    [0306/] Failed to launch child process
    [0306/] Failed to launch child process
    [0306/] Failed to launch child process
    [0306/] Failed to launch child process
    [0306/] Failed to launch child process
    [0306/] Failed to launch child process

  • After installing Opera developer 29.0.1794.0 (windows 8.1 32bit) i installed java 8.40 and now java doesn't work at all in the browser. When using the java test page I only get the error message that the page abended (i don't know the exact english text because the message is in german). Same when I try to test java applets. The java installation went well and i can test java successfully in other browsers like firefox.

  • Hi, I solved my java problem: it was caused by the plugin settings: I had not checked " execute all plugins" but "execute important plugins"

  • joakimwallden: When i started opera developer in the terminal just with opera-developer, it works. But when I start with sudo opera-developer, I get exactly the same error that you get; "out of memory"/"slut på minne" (I am from Sweden too). It seems like there is some sort of bug, perhaps we should move this discussion to a thread in the opera for linux category.

  • It’s the other way around for me. Opera works when started with sudo. O.O

  • joakimwallden: Try to change the owner of the files in ~/.config/opera-developer and ~/.cache/opera-developer to you. They could have been set to root.

  • Thanks gustavwiz. Those folders are mine. I uninstalled 29.0.1794.0 and installed 29.0.1788.0. Runs with no problems.

  • Why not just move the tab site on the sidebar (Ctrl Shift C)? In addition Extensions Sidebar add move option.

Log in to reply