Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Can you disable keyword search engine?

  • Is there a way to disable keyword search engine? Like when you type
    "y" <some word> into the url, it searches <some word> in yahoo.

    Like this setting:
    f541a892-b5aa-49a3-a6de-790fb0855455-image.png

    Im personally not a huge fan of this shortcut/keyword, and I've never used it. If anything its more annoying then it is helpful, because sometimes I do search one letter things and space with another word it uses the search engine keyword.

  • If you want to search for "y something" you just have to prefix it with your desired search engine, for example "b y something". But no, you can't modify the built-in search engines at all.

  • @sgunhouse Oh I see.

    However, I run into another problem. Which I assumed comes from the keyword built-in search engines, but im not entirely sure because it never happened before so it may just be something unrelated.

    Sometimes I like to type one letter and click enter in the url, which it normally will autofill a common site I visist like "youtube". However, recently I get this:
    eda729de-8a57-47b4-bca0-aa667242acbf-image.png

    2f0e74ab-e2b3-412d-90f2-72f43d5ab418-image.png

    Not entirely sure why this happens, and I just assumed it was from the "y" keyword for yahoo search engine. Its not like that url is even in my history and I can't remove it from my search, so I assumed it was the "y" keyword.

  • @hion Not sure if it'll help in this situation, but goto the URL opera://flags/#suggestion-scoring-improved, disable the flag, restart Opera and try again. You may have clear your history after that too, but not sure.

  • @burnout426 Just tested, doesn't seem to work. Thanks tho

  • @hion There are other sites starting with Y that you visit often?

  • @leocg No not really. However, oddly enough, after updating Opera from Settings > Upate & Recovery then relaunching Opera. It manage to fix the issue, and I don't seem to get that weird autofill anymore.

Log in to reply