Font rendering in 12.17

  • Opera is displaying fonts oddly in some locations.

    Example one. https://theadminzone.com/
    Scroll down to where is says "Forum Software." Right underneath it has a list of subforums. It is not displaying bold and font size correct. And what's odd is the problem is not always the same. And on rare occasions is displays okay. But this displays okay in other browsers every time.

    Example two. http://www.woltlab.com/forum/index.php/Thread/227453-Community-Calendar-2-0-Released/
    Move your mouse pointer of a message. Buttons will appear in the lower right corner. These are CSS buttons. The first one is supposed to be the quote character "\f10d." But this one and the rest don't display what they should in Opera. But they display okay in other browsers

    Example three. In the Opera forum here where it is supposed to say "sign out," it is blank square. Other things are wrong too. In other browsers it's okay.

    Is there any way to fix this?

  • One thing I was able to find out from another Opera user is it's not happening to him. And he too is using Windows 7. It appears to me to be an encoding problem, so I tried every English language setting under the View menu. No help. I also tried Automatic Selection but no help.

    But I was able to temporarily fix it. I happen to be on this page: http://tvline.com/2013/08/04/the-killing-season-3-finale-recap-skinner-elias-koteas-is-the-killer/. It was displaying oddly. So from the menu I selected View|Encoding|Automatic Selection. It got fixed for that page and all other pages where I had problems before. That is until I quit and restarted Opera. And, of course, I tried picking Automatic Selection at the other places, but it didn't work there. Can someone look at that page and see why this page fixes it? I looked at the source and could see nothing to help me.

    Also, is there some setting in Windows that might be confusing my copy of Opera?

  • Do you block websites/URLs?

    Or did you disable webfonts?
    See opera:config#UserPrefs|EnableWebfonts

    My be its a problem with hardware accellaration.
    Try to disable with opera:config#UserPrefs|EnableHardwareAcceleration

  • Thanks for the suggestions. I made sure and it's set as you suggest. I also made sure Author mode was set to default. I checked language, and it's set to iso-8859-1, the same as another Opera user who is having no problems.

    Is it possible to just install the previous version of Opera over this one? I don't think I had this problem with 12.16.

  • I forgot to actually say that I'm still having the problem. That's why I'm asking about downgrading.

  • Problem solved

  • Problem solved

    Ok, I guess we'll never know how though.

  • I did a fresh install.

    And, I also noticed that I had installed the International version before when I should have installed the English (US) version. I don't know if that made a difference, though, because the problem didn't show up right away.

  • Thanks for returning and posting what you did do, even if it may not have been what cured the problem, at least it gives others who may have the same issue another option to try.

  • No problem. In that case, I'll add this.

    My fresh install was the 64 bit version instead of the 32 bit version I had been using. I installed the 64 bit into the default 64 bit install folders, so it would not overwrite my 32 bit version. That way I could compare my settings between the two of them to help me set up the buttons and skins the way I like. Then I copied files that handle bookmarks, wands, and speed dial directly from the 32 bit to the 64 bit. I'd post the file names, but because I'm not sure I did it exactly right, I'll leave that out. All I can say is after some fumbling around, it worked.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.