Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Speed Dial folders not opening after updating to v70

  • I just updated and ran version 70 for the first time (70.0.3728.71), checked the history bug is still there, so then I tried to come to these forums. I clicked on a Speed Dial folder but nothing happened... Speed Dial markers worked, but not folders. Closed Opera, reopened, and the folder worked. "Great!" I thought. Well, after creating a new tab, it happened again.

    So it seems speed dial folders work only the first time. After that, clicking on them does nothing, not even in a new private window.

    It might be worth mentioning that I've disabled the flag #shared-start-page.

  • @alobpreis Any difference if you enable it?

  • It doesn't happen when I set it back to Default [E]. And fortunately I see that the issues I mentioned back in this topic are quite solved:
    https://forums.opera.com/topic/40532/speed-dial-is-the-same-across-tabs
    Although when opening a new tab you could still see a flash of how the previous Speed Dial was before.

    So it seems this is an issue that happens with Speed Dials except the first one (shared or not), just that if it's shared, you are always stuck to that first one and don't experience the problem.