Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

[BUG] Opera won't check for updates - invalid params and unable to prepare update checker runtime

  • Opera doesn't check for updates, either on the About Opera page nor on the Update & Recovery page. When I run opera_autoupdate.exe, I see in the logs:

    [20412:15260:0110/113335.943:48775718:ERROR:autoupdate_checker.cc(323)] Invalid params.
    [20412:15260:0110/113335.943:48775718:ERROR:autoupdate_checker.cc(137)] Unable to prepare update checker runtime.
    

    You can also see on one of the screen prints the Check for update button is greyed out:

    Update & Recovery screen.png About Opera screen.png

    Tried reinstalling multiple times, including using offline.

    Version: 66.0.3515.27 (although it's been happening for the last few versions - not sure how many back)

  • Just installed 66.0.3515.36. Problem still exists.

  • And the problem also exists in 66.0.3515.44. Is there a better place for me to post this bug so it gets visibility? I would think it would be important.

  • @no-name-opera Did you try using a clean profile?

  • @leocg I did. I also tried installing just the stand-alone version. Same problem. Other thoughts on how to troubleshoot?

  • @no-name-opera Maybe something is blocking Opera's autoupdater?

  • @leocg That might be true but my challenge is how to troubleshoot what is blocking. Is there any command (in Windows) or startup flag that can generate a complete log of what it's trying to do and where it's getting rejected?

  • @no-name-opera Try disabling antivirus, firewalls and related software.

  • @leocg Already tried disabling everything.

  • I doubt this will help troubleshoot but, when I updated to 66.0.3515.44, I see this in the debug log:

    [0123/100111.306:WARNING:minidump_to_upload_parameters.cc(67)] duplicate annotation name prod, discarding value OperaDesktop
    [0123/100111.306:WARNING:minidump_to_upload_parameters.cc(67)] duplicate annotation name ver, discarding value 66.0.3515.36
    [0123/100111.307:WARNING:minidump_to_upload_parameters.cc(67)] duplicate annotation name channel, discarding value Stable
    [0123/100111.307:WARNING:minidump_to_upload_parameters.cc(67)] duplicate annotation name ptype, discarding value renderer
    [0123/100113.650:WARNING:minidump_to_upload_parameters.cc(67)] duplicate annotation name prod, discarding value OperaDesktop
    [0123/100113.650:WARNING:minidump_to_upload_parameters.cc(67)] duplicate annotation name ver, discarding value 66.0.3515.36
    [0123/100113.654:WARNING:minidump_to_upload_parameters.cc(67)] duplicate annotation name channel, discarding value Stable
    [0123/100113.654:WARNING:minidump_to_upload_parameters.cc(67)] duplicate annotation name ptype, discarding value renderer
    
  • Try Fiddler app, once the blocked URLs / IPs appear, search them on HOSTS file, router blocking tab, change DNS...

    --
    "Off topic Tip"
    Follow the Signature's BackUp | Reset link.
    Take the opportunity to start a Backup plan, even create a Template Profile.

    SyncBack | Synkron helps.


    Windows 7 (x64)
    Opera Test profile | Opera Back up | Reset

  • @zalex108 Well, isn't that a neat little tool. Thanks for the suggestion. However, it doesn't show any errors - HTTP 200 across the board, including http://autoupdate.geo.opera.com:443 (which, I assume, is the auto-updater pinging) and http://extension-updates.opera.com:443. What's confusing is that these use http as the scheme but go over port 443 (secure). I'm sure there's a reason but that's the only noticeable oddity. Other thoughts?

  • @no-name-opera

    I don't know.

    Try pinging them.
    If they showed as non blocked should respond then is quite extrange. πŸ€”

    πŸ‘Ύ

  • @zalex108 Here are the results:

    PS C:\> Test-NetConnection autoupdate.geo.opera.com                                                                     
    ComputerName           : autoupdate.geo.opera.com
    RemoteAddress          : 37.228.108.132
    InterfaceAlias         : Wi-Fi
    SourceAddress          : 192.168.1.9
    PingSucceeded          : True
    PingReplyDetails (RTT) : 38 ms
    
    PS C:\> Test-NetConnection autoupdate.geo.opera.com -port 443                                                           
    
    ComputerName     : autoupdate.geo.opera.com
    RemoteAddress    : 37.228.108.132
    RemotePort       : 443
    InterfaceAlias   : Wi-Fi
    SourceAddress    : 192.168.1.9
    TcpTestSucceeded : True
    
    PS C:\> Test-NetConnection http://autoupdate.geo.opera.com -port 443
    WARNING: Name resolution of http://autoupdate.geo.opera.com failed
    
    
    ComputerName   : http://autoupdate.geo.opera.com
    RemoteAddress  :
    InterfaceAlias :
    SourceAddress  :
    PingSucceeded  : False
    
    PS C:\> Test-NetConnection http://autoupdate.geo.opera.com
    WARNING: Name resolution of http://autoupdate.geo.opera.com failed
    
    
    ComputerName   : http://autoupdate.geo.opera.com
    RemoteAddress  :
    InterfaceAlias :
    SourceAddress  :
    PingSucceeded  : False
    
    PS C:\> Test-NetConnection https://autoupdate.geo.opera.com -port 443
    WARNING: Name resolution of https://autoupdate.geo.opera.com failed
    
    
    ComputerName   : https://autoupdate.geo.opera.com
    RemoteAddress  :
    InterfaceAlias :
    SourceAddress  :
    PingSucceeded  : False
    
  • @no-name-opera Is your connection set as limited by chance?

  • @leocg I'm sorry but I don't understand the question. I'm not aware of any setting in Opera to limit the connection (and I just did a search to check). And I've tried the update with VPN both on and off. If you're referring to Windows overall, no, I don't have any limits set (as far as I know) and have more than ample connection speed. Can you be more specific please?

  • Do you have a custom Hosts file or DNS?

    Try disabling the Hosts file and with Google DNS 8.8.8.8 or Open 1.1.1.1.

  • @zalex108 I had a custom Hosts file to block much of Microsoft's crap tracking but just got rid of it and also tried Google DNS. Same problem.

  • @no-name-opera Google 's dns was act 'n up earlier..

    open dns is work 'n
    208.67.222.222
    208.67.220.220

  • @nvmjustagirl Sadly, same problem.

Log in to reply