Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • The "Scroll to the top of the page" option, does't seem to work in forum page. Can you please confirm?

  • This forum? They divide the page into pieces and the top bar is always shown, so I'm not sure ... does the Home key on your keyboard do anything different?

  • @stolis It seems to be working here.

  • @leocg Well it's mysterious. Now it seems working, but an hour ago it didn't. But i have seen this happening on other sites as well. What to say ? 😮
    Thanks for the reply 👍

  • Well, it happens again. It dosen't works. I really can't explain it.

  • @leocg Still having problem. It appears again today. I've tried reload, log in and out, closed and reopen opera but non seems to work. On other sites it's working fine. Is there something else i could try? I really can't understand why is this happening!

  • @sgunhouse Well, the home key works fine but clicking on the tab doesn't. Same problem appear today. On other sites though works fine. I'm really confused with this one!

  • @stolis When it doesn't work? There is a pattern?

  • @leocg Sorry to bother you again, but i really can't figure out what's wrong. Right now it doesn't works. I opened the forum page in another tab and it does. I'm getting nuts with this. Don't know what else to do but it's really strange 😯
    Do you have any other suggestion ?

  • @stolis How are you checking it?

  • @leocg Well, I've tried several ways. Going up and down with Home & End through the keyboard, scrolling with the mouse wheel, the scroll bar and non of this seems to work when i click on the tab. By reopening the page in another tab, it did. It's really weird. And sometimes that appears on other sites i have to reload the page.

  • Few min ago i logged out & closed the tab. I reopened the forum page and worked. But after loggin' in and coming back to the topic it doesn't. I opened the topic in a new tab and worked. Closed the new tab, came back to the forums first page and again nothing. 🤪
    I'm going to close and reopen the browser to check it again to see what will happen.

  • Nope. It didn't worked. But this time I've noticed something. The problem seems to appear after login in. Before that it works fine. For gods sake, what's goin' on?

  • @stolis Just tried in this page and scroll to top is working.

  • @stolis Maybe it's because you are coming from another site?

  • @leocg Hello again. After some tests I’ve noticed several strange things that don’t look quite right.

    1. In order to open the forums page I use the tile I’ve added into the speed dials page. By entering the page the scrolling feature works fine. The problem appears after login in. It stops functioning.
      By choosing to open in a new tab though, the feature works again in the new one whatever i do (Back & Forward, open any topic, reload page etc.).
      Can you explain this? Because it certainly looks strange to me. 😨

    2. Regarding your question (...another site), I really can’t understand why’s that should affect the feature. By the way i’ve got an example about it (not being sure if it’s related).

    I’ve opened operas official site (, where the feature works ok and by clicking the forums link at the end of the page it opens a new tab directing to the forums home page. And (check this out) the feature doesn’t work.

    But again, choosing to open the link in a new tab, it comes back alive. Until login of course, where it stops. One last thing. After login out, I went back to operas site using the link from my bookmarks and the feature wasn’t working. All these being in the forums tab. But for once more, opening it in a new one, it works. The curious thing is that choosing another site i’ve got no problem !!!

    All these seems very strange. Am I the only one facing this kind of malfunction & where it comes from? It's confusing me 🤪
    Sorry for getting you tired with this one but any help would of course be appreciated.

    By the way (sorry that I forgot about it) I’m using version “65.0.3467.62” (x64) on a “Win10-1909” (x64) system.

  • @stolis Regarding 2, it may be because of strict site isolation, known for be causing similar issues.

  • @leocg Is it logical having such a problem between their own pages, 'cause i don't get it?
    At least, could you check it out in your free time? Any suggestion?

    The most annoying is that the problem appears after login in. Any explanation on this?

  • I can confirm the problem in Opera Stable (last 65 build) at least.

    • In a new tab, while not logged into these forums, paste n go

    • Scroll down the page and then left-click the tab to scroll to the top. Left-click the tab again to scroll where you were at.

    As you'll see, the scroll-to-top feature works fine.

    • Click "Login" at the top right, log in, and wait to be redirected back to the page.

    • Try scrolling down the page and left-clicking the tab again.

    Result: Opera does not scroll back to the top.

    I assume that Opera's scroll-to-top feature is implemented by an internal component extension that is getting denied permission to run on the page when redirected from to That's just a guess though.

    With that assumption, I closed Opera and started Opera with the --disable-site-isolation-trials command-line switch.

    "C:\Program Files\Opera\launcher.exe" --disable-site-isolation-trials

    Then, the problem goes away.

    With that said, maybe there's some Cross-origin policy headers and can use to work around it. But, not sure. If not, it might have to be something Opera would need to fix if possible.

    @amatczak, @lmormol-op, @gmiazga

  • @burnout426 Thanks for replying. About the command, i'm not sure how to use it. Where do i put the "--disable-site-isolation-trials" command exactly!
    The problem does appear after login. What i can't understand is how nobody else seems to have this problem. And of course it's not normal to use extra commands every time, in order to make it work. Don't you think?
    Just a little help with the command to check it out, though i believe it's a real problem they should fix.