Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera and 5.1 or 7.1 sound

  • @pwhodges said in Opera and 5.1 or 7.1 sound:

    https://cassland.org/sounds/TestQuad/

    That's a good test. I can reproduce the problem even with only a 2-channel setup. Had to go back to Opera 64 for it to play. I was able to break it in Opera 64 by enabling opera://flags/#ffmpeg-demuxer-everywhere. That feature is always enabled in newer Opera without a flag to disable it. I filed DNA-85295.

  • @burnout426 Thanks for that!

    Paul

  • @pwhodges these switches may or may not help..

    --force-wave-audio

    --disable-audio-output-resampler

    and this flag perhaps Enable it..
    WebRTC multi-channel capture audio processing

    here is a test that might work for ya
    https://youtu.be/XdfmAkasBcc

  • @nvmjustagirl said in Opera and 5.1 or 7.1 sound:

    @pwhodges these switches may or may not help..

    --force-wave-audio
    --disable-audio-output-resampler

    Neither of those addresses the issue, which is the number of channels.

    and this flag perhaps Enable it..
    WebRTC multi-channel capture audio processing

    That's already set.

    here is a test that might work for ya
    https://youtu.be/XdfmAkasBcc

    It's another source of multi-channel audio, so it shows a similar failure. Not quite the same admittedly, as it plays, but only the front two channels.

    I guess that because the source is a video file, Opera doesn't reject it in the way that it appears to reject multi-channel pure audio files, and the different code path leads to it either downmixing to stereo, or just taking the first two channels, or (conceivably) selecting an alternate stereo stream from the video.

    Paul

  • @pwhodges i asume ya ran switches 1 at a time.. *Sowwies that was my fault..

    So run these 3 switches all @ the same time

    Example

    "C:\Users\name\AppData\Local\Opera\launcher.exe" --disable-audio-output-resampler --try-supported-channel-layouts --force-wave-audio

    see if it helps..

  • Um, you seem to assume that I didn't try those things, even though they are pretty clearly irrelevant.

    Also, note that a couple of posts above burnout426 identified a change in Opera which correlates with this problem and has raised a bug for it. This fits the fact that it used to work by default and now doesn't.

    Paul

  • @pwhodges said in Opera and 5.1 or 7.1 sound:

    Also, note that a couple of posts above burnout426 identified a change in Opera which correlates with this problem and has raised a bug for it. This fits the fact that it used to work by default and now doesn't.

    Paul

    even tho chrome may work for ya other peeps it does not..

    it just wasn't opera..

    Chrome Version 79.0.3945.88 removed the flags that was needed..

    In Google Chrome Version 80.0.3987.106 this switch helped
    --try-supported-channel-layouts

    even tho it was a bug.. it was a work around for the problem..

    since peeps are wait 'n on a fix..

    n e ways thats all i was try 'n to say.. *its all good.. am sorry for try 'n to help..

    there is one other thing ya could try while waiting for a fix, but its up to you if ya wanna me to post..

  • @pwhodges i did not over look burnout..Don't despute @ all..

    and i did not overlook what you said - ya did or did not have trouble with sound on and off till new updates.. and now ya don't have surround sound in opera That you stated.. Perhaps ya overlooked ya own post..

    even tho burnout found what he found
    you said you had sound b/4 update

    i think your the only one lately that has surround sound not working.. that goes for peeps use 'n opera and chrome..

    the things ya call - pretty clearly irrelevant.. will not be irrelevant..

    i thought the switches may work w/o changing n e audio settings.. for most it worked..

    Note - i figured i guess that ya might not wanna fiddle with your cards settings..

    not unless you can put it back like it was..

    so i'm gunna try to explain incase others have the trouble too..

    If the above post either doesn't work or stops working in the future (AGAIN!) For opera/chrome.

    depending on how old audio card is..

    Changing the Audio mode to (Audio Creation Mode)

    (most SB cards have this mode) i dunno if ya card has this option..

    but if so

    Select Multi-Channel Wave

    Under the "Front L/R" fill the check boxes for Rear L/R & Front C/Sub and
    it will force the 5.1 signal from opera/chrome that only has the stereo channels being used - to use the L/R Front signals and redirect it to each checkbox you fill !..

    this example is (SB card).. with Highlights were ya do changes..

    97bc94dd-b02e-47d9-9063-260ecf3c6ead-image.png

    its up to you to try or not.. while waitig on a fix *just say 'n..

    if nothing works i guess your stuck till opera fix.. *Go Opera Team..

    n e ways i'm out.. *hope ya get troubles fixed soon..

  • @nvmjustagirl said in Opera and 5.1 or 7.1 sound:

    --disable-audio-output-resampler --try-supported-channel-layouts --force-wave-audio

    I tried that with https://cassland.org/sounds/TestQuad/ just to see if it helps make the player work for me, but it does not.

  • @nvmjustagirl

    Everything you have suggested is related to how Opera plays a surround file. The problem is not at that level. Opera is not accepting that a four-channel aac/m4a file is something to play at all. This is clearly shown on the other page I gave a link to:
    https://tetrahedral.audio/ta-recording

    Halfway down you will see this:
    HTML5 players

    No clever Javascript player like the other test page - just raw HTML5 audio elements. The top one links a stereo file, the lower one links a surround file. You will see that the lower one is greyed out; you cannot click it - Opera will not even attempt to play the file.

    Paul

  • https://blogs.opera.com/desktop/2020/05/opera-70-0-3701-0-developer-update/ has a fix for 4-channel audio. Please test in this build to make sure things are working now.

  • @Unexplainable said in Opera and 5.1 or 7.1 sound:

    @burnout426 The sound works fine in Vivaldi & Brave, thanks for the help, I did not know about such browsers!

    You learn something new everyday! 🙂

  • @burnout426 said in Opera and 5.1 or 7.1 sound:

    https://blogs.opera.com/desktop/2020/05/opera-70-0-3701-0-developer-update/ has a fix for 4-channel audio. Please test in this build to make sure things are working now.

    Thanks - that's working fine now.

    Paul

  • @pwhodges Thanks for the confirmation.

Log in to reply