Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

[Solved]Video playback issues with MacOS Catalina

  • @ErkamCalik I have the same problem (Netflix streaming error). Using Opera 64 with MacOS Catalina. Downgraded to version 63 and it worke. However, autoupdate keeps working and it goes automatically to version 64. I have tried to disable using both solutions described in the link (terminal and changing the name of the EXEC file in the app contents, but Opera updates regardless... How were you able to stick to version 63?

  • @archimdx I'm glad that it worked! As per the auto-update, I just typed defaults write com.operasoftware.Opera OPDisableAutoUpdate true in the terminal and hit enter! And it worked like a charm for me! Here are the screenshots. As you can see, it says "Update checker is disabled."

    Opera Snapshot_2019-10-11_091853_about.png Opera Snapshot_2019-10-11_091918_update.png

  • @ErkamCalik Thanks for your reply... however, I must be doing something wrong... My process: I deleted Opera in the Apps folder; dowloaded Opera 63 from the FTP page; run the dmg file to install; before opening Opera 63 for the first time, I use the terminal to paste defaults write com.operasoftware.Opera OPDisableAutoUpdate true (copied from your message, to be sure); opened Opera 63... Opera instantly starts the update... Screen Shot 2019-10-11 at 06.23.25.png

    Screen Shot 2019-10-11 at 06.25.54.png

    ... and I am back with Opera 64... where Netflix and Amazon do not work. I guess I will have to move on to Safari or Chrome, while this gets solved in a future Opera update..

  • @archimdx Hello again! This is so weird! 😕 I did the same and it worked for me! You might want to check to see whether they are other ways to disable auto-update. Sorry! 😕

  • @ErkamCalik I see that you are in a different MacOS version, I guess that is part of it... I filled in a bug report... But thanks again!

  • @archimdx btw the FTP page shows that there is a newer version: 64.0.3417.54. They've added the MacOs version on the webpage today!!!. I had the Netflix problem when I was running version 64.0.3417.47.

    So maybe downloading this latest firmware might be the solution! If it works, keep us posted 🙂

  • @ErkamCalik No there yet:

    Screen Shot 2019-10-11 at 08.35.48.png

    Screen Shot 2019-10-11 at 08.36.41.png

  • @archimdx this is such a pain in the ass! And i'm surprised at how only 4 people have posted in this thread! All in all, version 63 seems to be the most stable, if you can keep it that way 😃

  • @archimdx Try disconnecting from the internet before installing Opera 63.

  • @leocg Just tried it... disconnected before installing, run terminal command and even so, Opera keeps checking to update. If I quit, and run terminal command again, it still tries... As soon as I reconnect, Opera gets the update... My guess is that it is a combination: Opera 64 does not work well with Netflix and Prime Video, and MacOS Catalina is preventing me from disabling Opera auto update...

    Screen Shot 2019-10-11 at 09.07.23.png

  • This is clearly a bug. Nasty, embarrassing regression. If you look at other threads on Opera for Mac forum - there are more issues with video playback on Catalina. I guess someone forgot to extend test matrix with new OS, even though it was in beta for quite a while.
    Shame on you, Opera. Hopefully we'll see a fix soon.

  • Environment:

    Screen Shot 2019-10-11 at 2.20.06 PM.jpg

    Can not play video after updated to Catalina.

    Any thought?

  • On Opera 64 for Mac, various releases, but on the latest stable release. Since updating to 64bit MacOS Catalina, videos in Tumblr or Instragram no longer play. They stutter for about a frame or two, then stop. Help, please.

  • @amnezia Had the same problem with Instagram videos. By enabling "Use FFmpegDemuxer to demux all media files" in "opera:flags", the problem was solved for me. Maybe it works also for Tumblr.
    It doesn't solve the Netflix problem.

  • @archimdx What if you run the opera with the switch as follows: /Applications/Opera.app/Contents/MacOS/Opera --disable-update, does it work, or still trying to update?

  • Hello, Guys. I've got the same problem with Opera and MacOS Catalina but my Netflix works, Youtube also but other video players froze at frame or two also. Safari works fine. So sad.. EDIT: Netflix does not work...

  • I have the same problem running macOS Catalina and Opera 64.* so tried to switch back to 63.x.x.107. The shell command to disable autoupdate didn't work. Deleting the autoupdate from inside the Opera.app would cause a file is corrupt error.

    What did work was using terminal to zero out the update files after downloading and installing the Opera.app.

    echo "" > /Applications/Opera.app/Contents/MacOS/opera_autoupdate
    echo "" > /Applications/Opera.app/Contents/MacOS/opera_updateinstaller
    echo "" > /Applications/Opera.app/Contents/Versions/63.0.3368.107/Opera\ Framework.framework/Versions/A/Helpers/opera_autoupdate

    You will need to change 63.0.3368.107 to the version of Opera you wish to run, but disable the autoupdate.

    Hope this helps.

  • @gnubee This worked! I deleted Opera 64, downloaded and installed 63.0.3368.94 from the FTP index and let it update to 63.0.3368.107 - Before launching Opera again I used the the terminal commands you suggested, and that's it... I get the message "An error occurred while checking for updates" when checking "About Opera" in the menu, but it stays put in that version. Netflix and Prime Video now work fine. ☺ Thanks!!

    Screen Shot 2019-10-13 at 06.28.00.png

  • We're aware of the issue and it'll be fixed in the next update to Opera.

    For people struggling with automatic update, it's much easier to disable it like this (and easy to revert later too):

    Open Terminal.app and write

    defaults write com.operasoftware.Opera OPDisableAutoUpdate true
    
  • Hi everyone-first let me say, I am not a software or PC expert but I"m pretty good at following directions. I prefer Opera to Safari, Chrome and Firefox. I upgraded to Catalina a week ago, and have had numerous issues. I can watch videos in some sites but not all, Youtube is fine, however some sites say, HTML5 video not found. I've checked the same site on other browsers and the videos play fine. I'd prefer to stick to Opera for my needs. I downloaded the latest version of Firefox and it keeps freezing up. I prefer not to call to call Geek Squad to fix a few of the these issues. So if anyone knows of a fix or a suggestion, I'd much appreciate the help. Thank you.

Log in to reply