Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Google Translate audio buttons

  • Hi. I've installed Opera few mins ago and here's the first problem - there is no "Say-it" and "Play" buttons in Google Translate. How can I fix it?

    [Closed as duplicate of: https://forums.opera.com/topic/3127/google-translate-has-no-voice ]

  • Whar are those buttons? I can see a "listen" button here.

  • I have the Google Translate extension, and I don't see the buttons. It works fine but without the "Say-it" "Play" stuff.

  • Whar are those buttons? I can see a "listen" button here.
    Leocg, yup, right, there should be "Listen" and "Say-it" buttons. They exist in Google Chrome but not in Opera.

  • Whar are those buttons? I can see a "listen" button here.
    Leocg, yup, right, there should be "Listen" and "Say-it" buttons. They exist in Google Chrome but not in Opera.

    What the "say it" one is suppose to do? It appears on browsers other than Chrome?

  • @leocg:

    Button will spell word(s). I tested current browsers:

    • Working: Firefox 30.0, IE 9.0.8112.16421 x86/x64, Opera 12.17 b1863 x64

    • Not Working: Chromium 37.0.2056.0 (Developer Build 277762), Opera 22.0.1471.70, Opera Developer 24.0.1534.0, SRWare Iron 35.0.1900.0 (Official Build 280000), TorBrowser (Firefox ESR) 24.6.0

    @
    I tried this extension Translator, and spelling is working just fine.

  • Same here. No listening button on google translate page. Opera 22.0.1471.70.

  • Button will spell word(s). I tested current browsers:

    I'm not seeing that button on IE11 and neither on FF 30.

  • I do not have the listen button in Opera.

  • Firefox 26 has got the listening button. Chrome as well.Even OPERA 12.17 has got the button! It is obviously an error in the newest Opera.

  • It's missing with the regular NPAPI Flash but it appears when you use the Pepper Flash (currently in beta).

    I have already reported this issue as OTW-9453 before...

    Here's an earlier thread: https://forums.opera.com/topic/3127/google-translate-has-no-voice

  • I have just discovered that changing User-agent to Firefox fixed this issue. When I tried Chrome - no effect. Firefox - this is a surprise - it works!

  • I have just discovered that changing User-agent to Firefox fixed this issue. When I tried Chrome - no effect. Firefox - this is a surprise - it works!

    So it looks like google is browser sniffing again.

  • On the Google Translator, there's a note for Opera Users http://add0n.com/google-translator.html?version=0.2.5

    To enable text-to-speech feature of the extension you need to have a media player plug-in (mp3 supported) installed on your Opera browser. Please follow this instruction to install QuickTime plug-in.

    I have my user-agent option set at default. When I installed that plug-in, if I just double click before a word, the word becomes highlighted, I then get the word translated in a pop-up and there is a voice option that works -- I can hear the voice. However, if I select and copy more than one word -- maybe a sentence -- and press enter, you go to a website for the translation, and there's no voice option. However, if I change the user-agent to Firefox, then I get the option for the voice feature, as well as the translation of the sentence on that web page.

    I'm not sure I like having the user-agent setting Firefox, so I'm keeping the user-agent at "default" and am satisfied with just being able to get a one word translation by voice via the popup.

  • I have the listen button in Internet Explorer however Opera does not have it. Maybe browser snuffing again?

Locked