Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

How to disable Google Translate. I can do better on my own. I do NOT have any translate extensions

  • How to I turn off Google Translate? The translation that is comes up with is ludicrous. I can do better on my own.
    It did show up until today and now it pops up when I access any foreign language page.
    I read on the internet to go into Chrome, well, I don't have Chrome, I have Opera. Nothing I've found so far has resolved the problem.
    Your help would be greatly appreciated.

    And during the writing of this short note, I've got four messages that Opera forums have disconnected and I need to wait (now five messages) until it reconnects. What's up with that? No problems like this on other webpages.

    Your help would be greatly appreciated.

  • @morlaine Since Opera doesn't include Google Translate, you need to find out how you enabled it.

    When are you seeing Google Translate being used?

  • Presumably that first site was in a frame, and any links clicked inside the frame would stay in the frame. Links opened from the address bar or Bookmarks should have been normal.

    Google will offer translation links in foreign-language Searches, but there should be an easy way to open the original as well.

  • @morlaine I have exactly the same problem. It's ridiculous.

  • Hi there,
    @leocg What do you mean with enabling it? About when, he said everytime he opens a foreign language page (It's the same for me)
    @sgunhouse I don't see what should we do then... I'm always opening bookmarks and that suggestion still apears almost everytime

    502a00e1-b4f1-4b76-8c76-47574519dcf4-image.png

    I believe that adding this option could help in case what's missing is the option to deactivate the suggestion, but I don't know...

    Can someone help disabling Google Translate on Opera?

  • @morlaine
    Okay if u still have this problem I found a solution. Install this extension (https://addons.opera.com/pt/extensions/details/translator/) in a normal website search for the extension in the toolbar. Then click in the three points button, and select in "page acess" "run on click".
    I don't know if u can just uninstall it, but like this it worked for me.

  • @unnamedguy As I said, Opera doesn't offer a translation tool. So either you are using an extension or the site itself is providing the translation service.

    It's not an Opera issue.