Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Bookmark bar reappears even after disabling it repeatedly

  • When I hit ctrl + d to bookmark a page, if "bookmarks bar" was the last-selected location, the bookmarks bar will automatically show with "Bookmarks bar" selected in the drop-down in the Bookmarks dialog that shows up. But, if I click that drop-down and switch to "other bookmarks", the bookmarks bar automatically disappears. I can swicth back and forth between "bookmarks bar" and "other bookmarks" in the drop-down in the dialgo the bookmarks bar with switch on and off to match.

    If I hit ctrl + d to bookmark a page where the last-selected save location is "other bookmarks" (as in, anything but "bookmarks bar"), the bookmarks bar isn't automatically enabled.

    That behavior seems makes sense to me. However, I can understand that some users might want to save to the bookmarks bar without it automatically showing where they only enable the bookmarks bar themselves when and if they're ready. But, if one never plans to make use of the bookmarks bar at all, they should just set the save location to "other bookmarks" (anything but "bookmarks bar") and they'll be good to go from then.

    For users that never wanted to use the bookmarks bar and just discovered that all their bookmarks have been saved there, they can goto the URL opera://bookmarks, click on "Bookmarks bar", click in the area in the right-hand pane under the line that's under the "Bookmarks bar" text, hit ctrl + a to select everything and then drag the selection to "other bookmarks" in the left-hand pane. Then, create/update an bookmarks on the page and set the location to "other bookmarks" and you'll be all good.

  • @moppera It doesn't happen here on Opera developer 65, so maybe it's just a matter of time.

  • @leocg Good to know, thank you

  • @burnout426 said in Can't get rid of bookmarks bar:

    But, if I click that drop-down and switch to "other bookmarks", the bookmarks bar automatically disappears. I can switch back and forth between "bookmarks bar" and "other bookmarks" in the drop-down in the dialog the bookmarks bar with switch on and off to match.

    I should clarify. That's when there are no bookmarks on the bookmarks bar and I'm trying to add one. If there's already at least 1 bookmark on the bookmarks bar, switching back n forth between "bookmarks bar" and "other bookmarks" just adds and removes that bookmark from the bar. It doesn't shut the bookmarks bar off when switching to "other bookmarks". Nothing does. You have set it to "other bookmarks" to make "other bookmarks" the last-selected save location, close the dialog and then manually shut the bookmarks bar off. So, in that case, it can be a little more annoying. The way around it though is to just set "other bookmarks" for a bookmark and then manually turn the bar off. Then it won't come back up. And, to get the behavior I quoted, you need to clear the bookmarks bar of bookmarks like @popinjay01 said.

  • It's annoying 😡 😡 . The same issue on windows10 😞

  • @hannijke said in Can't get rid of bookmarks bar:

    It's annoying 😡 😡 . The same issue on windows10 😞

    In the bookmarks page, move everything in "Bookmarks Bar" to "Other bookmarks". Then, bookmark a page to "other bookmarks" so that "other bookmarks" is now the default save location. Then, it should stay off.

  • @jin8864y
    Same problem for week now - I've never experienced it before.
    I keep unchecking it, it keeps showing up.
    It shows up even when it's already unchecked (?!?).
    Help, anybody, please? This is really, really annoying...

  • @popinjay01
    Thank you! This actually worked!
    (But I don't know how it got changed to "bookmark bar" (from "other bookmarks") in the first place?!)

  • @tanjanjanja I've been getting this problem for awhile now. They will not fix it, and refuse to do anything about it. It's like they just do not care at all. And just shove it under with every other bug.

  • @leocg Just popped in, after having been banned for "shouting" ?? sheesh, Really?? anyway.. your "suggested solutions" such as use "alternative bookmarking" ...now... why should a person have to use some weird "other" method if opera has in it, a bookmarking program that ought to work properly? But doesn't because their is either a bug, or flaw in the program coding? Your replies did not address the issue which frankly, is The Opera team has a program glitch it needed to fix.
    Anyway, after nonsensical answers to a simple question, and then getting booted because I voiced my frustration at this.. I decided to look to a better solution on my own. I found it... I tested... then switched to VIVALDI.. seems they don't have the issue.... So. thanks to you being a snowflake and banning me.. I had the motivation to find a superior solution... and I've moved all our computers here to it.... Great Job Rufus!! See ya.

  • @sgunhouse I don't see any options as to where to save a bookmark other than to pick which bookmark folder I have already created. There is no multiple choice of where to save a bookmark in the drop down box. I see the bookmark bar pop up every time I save a bookmark which is annoying since I do not choose voluntarily to use the bookmark bar. Can you give us a definitive way to stop this???

  • It used to be that Bookmarks bar was not the first item in the list; I think since they rearranged the list you won't be able to avoid it.

  • Thanks for the information. It would be nice if the next update had this fixed being that just turning off the bookmark bar is not enough to fix this. Thanks again.

  • I am having this issue as well. It keeps showing up, can one of the people running opera please fix this? It's been like this for awhile. I do not see any 'options' or any solutions for this. I like using opera, please again can someone fix this?

  • @nikaalexandrov On the last Opera update, the bookmarks bar was placed at the top of the bookmark selection list. Even if you select the folder that you want to place the bookmark in, the bookmarks bar will automatically turn itself on. It is a pain in the a**, The Opera software developers need to fix this as soon as possible. There is at this point nothing that you or any other end user of Opera can do to fix this in their settings. We are stuck with it for now.

  • @graywoulf I agree, it is a pain in the backside, I've had it for awhile now. But I've had it before the last update. So it was there for me even before then graywoulf. It's irritating that they do not even bother to fix it. I love Opera it's a good browser, yet with all the bells and whistles you'd think the developers would go and take care of it.

  • I really like Opera too but little bugs like this as you said, are for some reason ignored. I have to wonder if the Opera developers even read these forum posts to see what is said about their work. 🤔

  • I've got the same problem for over a month now, suddenly out of nowhere.

    Anytime I click on the "heart" to bookmark a page, the bookmark bar opens by itself, I hide it everytime but it keeps opening at each click on heart, it's bothering. I wonder when it will be fixed thanks 😣

    Resetting parameters of Opera browser has changed nothing at all unfortunately

  • @graywoulf
    I sure hope so.
    Few days ago I thought that I had solved this problem - but no... The darned bookmarks bar started appearing again, every darn time I bookmark something.
    It's not that I bookmark any dangerous and/or secret material - it's mostly some things I need for the current translation I'm working on, some recipes (I like to cook...), etc - so my main problem is not the visibility of the bookmarks bar. The problem, for me, is the fact that it takes approximately 2 cm of the monitor screen height. Since my screen height is 26,5 cm, when you deduct everything that just must be on the top of the page, there remains 24,7. When you deduct almost 2 cm for bookmarks bar - it's not even full 23 cm.
    And I know that all of you understand this very well - i'm sure that we aren't just a bunch of nitpickers...

  • @floflo203
    I didn't reset it - I reinstalled it!
    And nothing.
    But this is Opera forum - I hope to God that somebody "up there" is reading all this...

Log in to reply