Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Backward and forward buttons on Logitech Mouse not working with Opera

  • @botisdale We solved the problem,. Just read above 😏

  • @dubhead Though the forum topic refers to Logitech mice, it's not limited to just those (mine, for example, isn't Logitech) - consequently, the 'solution' doesn't apply to me. And while I appreciate the proposed solution, I'd really rather they just fix the problem. Worked fine before, no reason it shouldn't again.

  • Keystroke mapping workaround no longer works. I'm on Opera 60.0.3255.170, macOS Mojave 10.14.5 and using Logitech MX Vertical. This bug really needs to be fixed by Opera devs.

  • @tcar984 said in Backward and forward buttons on Logitech Mouse not working with Opera:

    Keystroke mapping workaround no longer works. I'm on Opera 60.0.3255.170, macOS Mojave 10.14.5 and using Logitech MX Vertical. This bug really needs to be fixed by Opera devs.

    Can't confirm on MacOS High Sierra 10.13.6 - it's still working. But YouTube does something strange: At Channel landing page, Command+Left /+Right are used to switch the focus of the tabs "Overview" - "Videos" - "Playlists" etc. So if the Webpage is listening to the keystrokes, they don't work in the browser window (except you pull focus off of it).

  • I got the same problem since the first stable version of Opera 58. The three finger swipe left/right gesture on my MacBook Pro is also still not working...

    I reported this bug months ago, got a mail that it will be fixed in a beta version, but this bug is still there.
    If an Opera dev is reading here: Are there any news about a bug fix? Thanks in advance!!!

  • Totally Worst Support ever Opera uninstalled 🙂

  • And you chose to make that as your first post, and to a year-old thread?

    And for the record, the buttons on my Logitech trackball work perfectly in all versions of Opera without any special settings.

  • @eprog625 Let's try to keep this positive. I agree that Opera haven't formally replied, and that is frustrating, however there is a good workaround.

  • @sgunhouse I have to disagree on that. With the Workaround of the Logitech Software setting, the backbutton on the mouse is now working, BUT the "focus bug" of the Opera Window still remains since half a year now. For example I am using the app "Magnet" to quicklyput windows on predefined corners of the screen, but with opera this only works if i have a single Opera Window opened. As soon I open a second Opera window, it doesn't work anymore and i have to close the browser. If i want to have to windows side by side I now have to use firefox on macos. The back and forward buttons and the app "Magnet" as well as other apps that help managing windows definitly worked with Opera 59 and lower (without any workarounds).

  • @sgunhouse The post is 6 months old, and whilst I agree that my logitech trackball is working fine, I paid a premium for MX Master and MX Master 2 devices and I would rather use them than my trackball.

  • @sgunhouse Sorry but this thread is less than 6 months old and the problem is not solved if you don't install Logitech software. Forward and Backwards buttons works like a charm out of the box in any other browser.
    In Opera buttons are working only while having the mouse on the border of the window.

  • @sgunhouse the fact that it works for you on Logitech trackball doesn't mean it works in general. For me on macOS even with Logitech Options installed it is not working when using MX Vertical. The only workaround I found successful is to move the mouse cursor to the far edge of the screen (to get a window resize cursor) and only then backward and forward buttons are working.

    Judging by the comments on the thread, conclusion is that your setup is an edge case and basic functionality is broken for majority.

  • The focus thing is a bug and should be fixed. Nothing to discuss about it as long as there are no news.

    @Luobin I'm using SizeUp on MacOS Mojave (10.14.6) and it works fine with multiple Opera Windows (63.0.3368.107). But yes, using another application should not be the solution.

    By the way: The bug is still not fixed as of update 64.0.3417.47

  • @albertchong
    I have been a Opera user since 2002 but never see this worst support!
    Bye-Be Opera Hello Safari + Chrome! 🙂

  • @eprog625 I sympathise. I've been using Opera since 1994.

  • @tcar984 said in Backward and forward buttons on Logitech Mouse not working with Opera:

    The only workaround I found successful is to move the mouse cursor to the far edge of the screen (to get a window resize cursor) and only then backward and forward buttons are working.

    That's my experience too. It's the only workaround I've found. I really wish they'd fix this because I do prefer Opera to Chrome for many reasons.

    Environment: MacOS High Sierra 10.13.6 with a non-Logitech mouse.

  • Hi guys...I had similar problems with my MX Master buttons behaving eratically / sometimes working, sometimes not, if certain apps or combination of apps were open. The solution, I found on another forum, was to allow Logitech Options to control my computer in System Preferences - Security and Privacy - Privacy - Accesibility. Just add the app to the list of apps that you allow to control your machine. This solved the problem immediately for me and lots of others. Hope this helps 🙂

  • @leononeill said in Backward and forward buttons on Logitech Mouse not working with Opera:

    Hi guys...I had similar problems with my MX Master buttons behaving eratically / sometimes working, sometimes not, if certain apps or combination of apps were open. The solution, I found on another forum, was to allow Logitech Options to control my computer in System Preferences - Security and Privacy - Privacy - Accesibility. Just add the app to the list of apps that you allow to control your machine. This solved the problem immediately for me and lots of others. Hope this helps 🙂

    Unfortunately I already had this setting configured and had to resort to programming the buttons separately as a solution.

  • For me, this issue got resolved when I upgraded to macOS Catalina. It could be that some of the system-wide configs were changed in the process...

  • @tcar984 Glad to hear it worked for you 🙂

Log in to reply