Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Warning Pop-Up When Opening from Desktop Shortcut

  • I have a windows shortcut on my desktop that launches Opera and specifies three different websites to open. When I double-click the link, Opera opens and displays a warning message for each of the three tabs it creates.

    How can I prevent this pop-up from appearing and have Opera simply open the sites in the tabs?

    This is the verbiage of the warning:

    Shortcut Trying to Open a Link
    Opera was opened by the shortcut with an unknown url from "http://www.ebay.com". Are you sure you want to open it?

    (or www.imdb.com or images.google.com)

    There is a "Remember my Choice" checkbox but it Opera does not remember if it is checked.

    This is the string in the shortcut's Target box:

    "C:\Program Files (x86)\Opera\launcher.exe" --private www.ebay.com www.imdb.com images.google.com

    Note that I see the same behavior when I omit the --private flag when opening Opera.

    1_1545316106376_2018-12-20_092332.jpg

    0_1545316106375_2018-12-20_092413.jpg

  • There is a tendency for adware to modify the desktop shortcut to direct you to their site; the idea is for Opera to warn you that such a thing may have happened. Though obviously in this case it is decidedly inconvenient ...

  • Try adding an exception in settings.

  • There's a setting for this under opera://settings/onStartup.

Log in to reply