Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • professorplastic about 10 hours ago

    I keep getting pop up messages asking me to allow things like notifications and a number of other things to be allowed.
    I have never found the need to say yes to these requests, but I can find no way to permanently switch off these requests FOR ALL SITES.

    There seems to be a site-by-site management feature where you can input every single site that you might imagine will ever ask you about these notifications, but there are about two dozens types of content and it seems illogical to input every single website I visit into these blocks, if a simpler switch exists.

    As I seem to never want these notifications is there a simple (or complex) way of PERMANENTLY switching off this plague of requests so that I can surf in greater peace.

    Unfortunately with all the GDPR requests this is beginning to make the act of simply trying to surf the web something of an ordeal.

    There is a complex way of doing this in Firefox involving editing the configuration files

    Best regards

  • As I see you posted this in two different forums - which is it, Linux or Windows? (Though as far as I know this isn't available currently and thus should be a feature request ...)

  • @sgunhouse both

    In firefox I can edit the configuration files in one installation and then copy that profile anywhere. This solves the problem universally.

    If this feature cannot be switched off in Opera maybe I can go back to an earlier version before these were features were introduced.

  • In settings you can disable desktop notifications in 'content settings'.

    However, based on what your report I would say that you are probably not seeing a notification request but just a regular pop-up.

  • i think By default, Chrome is set to ask when a site wants to deliver notifications. To turn them off completely, select the last option to not allow notifications. Next, click Done and then close the settings tab.