Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Cannot edit default search engine

  • Hello~ Aho~
    I'm using version 56.0.3013.0
    Starting from around 10 days before, I found that my default search engine was changed from Google to Baidu.
    The other recommended engines are mostly from China.

    0_1532179056989_opera.jpg

    I try to add Google on the list , set it as default and remove others.
    However those Chinese engines recover after re-opening the browser and Baidu become default again.
    I did search my case ,but it seems no one have this problem.

    What I guess are that:

    1. It is a new function on Opera which choose the best search engine base on Time Zone, and my PC's Time Zone is same with China's.
      Or
    2. My browser or my PC is hijacked.

    1. I change my time zone, but it is still happened

    2. Except "Opera Ad Blocker" , i don't have any other add-on.
      other browsers on my PC do not have this problem (Torch , Vivaldi)


    so, what's happen?

  • @felixy Using a custom search engine has never been possible in Opera. The option is there in Opera developer probably due to a bug in the new settings page.

    Are you in China? Default search engine may changes according to where the person is.

  • i find the version history as below, the 56.0.3013.0 is released roughly 10 days ago.
    it seems to be a bug.

    0_1532229941208_Untitledo.png

    Currently I am not in China. I arrived Canada 2 months before.

    Thx~

  • @leocg said in Cannot edit default search engine:

    The option is there in Opera developer probably due to a bug in the new settings page.

    And, last time I checked, Opera would revert your change on you after a restart.

  • What do you have set for the language under the Language section in settings? Do you use Opera's VPN or system VPN?

    What locale do you use in Windows?

    If you download the Opera installer, launch it, click "options", set "install path" to a folder on you desktop, set "install for" to standalone installation and install, does that Opera behave the same or do you get something better for the default search engines?

    You still shouldn't be able to set a custom search engine as the default though. That's not allowed.

  • @burnout426 said in Cannot edit default search engine:

    @leocg said in Cannot edit default search engine:

    The option is there in Opera developer probably due to a bug in the new settings page.

    And, last time I checked, Opera would revert your change on you after a restart.

    That's right!
    Just experienced an auto reuse of the last search engine used, didn't notice it fully about the reset.

  • @burnout426 said in Cannot edit default search engine:

    What do you have set for the language under the Language section in settings? Do you use Opera's VPN or system VPN?

    What locale do you use in Windows?

    If you download the Opera installer, launch it, click "options", set "install path" to a folder on you desktop, set "install for" to standalone installation and install, does that Opera behave the same or do you get something better for the default search engines?

    You still shouldn't be able to set a custom search engine as the default though. That's not allowed.

    On my PC, the Time Zone and location are both Hong Kong SAR while language is English (US).
    (But currently I am in Canada.) All VPNs are disable.

    With same setting of Time Zone and location, I installed the normal version of Opera (Version: 54.0.2952.60), and its default search engine is Google.

    So...it is Opera developer problem?

  • Opera remembers where it thinks it was. You should be able to edit the Local State file in your profile to remove the saved location, and it should correct it to your actual location.

  • @sgunhouse said in Cannot edit default search engine:

    Opera remembers where it thinks it was. You should be able to edit the Local State file in your profile to remove the saved location, and it should correct it to your actual location.

    For those who may have same problem

    the file directory is

    C:\Users\username\AppData\Roaming\Opera Software\Opera Developer\Local State
    "intl":{"app_locale":"en"},................"location":{"country":"hk","country_from_server":"HK",........................

    C:\Users\username\AppData\Roaming\Opera Software\Opera Stable\Local State
    "intl":{"app_locale":"en"},................."location":{"country":"hk","country_from_server":"CA",........................

    The only different is on "country_from_server:"

    It should be find after changing it. Maybe US or CA.

  • After I reporting the bug to the Opera Team yesterday, they release the new version 56.0.3023.0
    the "Local State" is still //country_from_server":"HK"//
    but
    the Google engine finally return!!!! yeah~~~

    Thank you Everyone and the Opera Team.

Locked