Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera stuck in Full Screen - no way out?

  • (Somehow) I accidentally triggered "full screen." All menu items are gone. I magnified every remaining icon and not one of them is a toggle back to proper-sized screen. I can't access my Mac. To get out I Force-Quit Opera and then restarted... and it WENT BACK TO FULL SCREEN. Firefox (for instance) has a little toggle icon on the upper right-hand corner of every screen (full screen or not). Why doesn't Opera provide a way to get out? And please don't tell me that I should "know" some kind of keystroke-combo shortcut. That's entirely unacceptable.

    0_1521066735862_Full_screen_Firefox.png

  • On Windows, you'd press Esc or F11 - Escape being a general cancel key and F11 being the key which causes full-screen mode in the first place. I won't guarantee Mac is the same, but try one or the other of those.

  • @sgunhouse Well, thanks... but not a PC. F11 on a Mac = increase volume. Escape does nothing in Full Screen (likewise Option-Escape and anything else I tried). I just want Opera to revise the expanded full-screen page so it includes a toggle back to normal-screen (with menus) like the example I show from Firefox.

  • Hi @michaelbix, ESC or Shift+Command+F will always exit fullscreen mode.

  • @kmielczarczyk Escape by itself... definitely does not remove Full Screen. Shift-Command-F makes whichever is the foreground window (of several) into the entire screen, by itself (or not)

    My problem is that Opera (multi-window) is Full Screen without showing menus or access to my desktop. My only possible solution is to use Command-Option-F13 which activates Mission Control (and forces contraction of the Opera window). A cludgy solution... best I have so far.

  • @kmielczarczyk The solution let itself be known. Opera in "Full Screen" is different than an individual page in full screen. The menu bar at the top disappears and there is no pathway back to other applications, let alone other open windows in Opera. All which appear are the tabs on the one selected (full screen window).

    Getting OUT of full screen proved to be easy... once I discovered it. No F-keys, no keystroke combinations necessary. It was a simple as moving my cursor to the very top edge of the screen. Then (Presto) the menu bar re-appears. The FullScreen/WindowedScreen toggle switch appears at the right end of the menu bar. Easy as pie. (No one in the Forum seemed to think that was necessary to tell me about.. but really... I didn't know and it was a really frustrating journey to discover it. Lost use of Opera for days, and had to enter the Forum from Firefox.) Just saying....
    ![0_1521337753682_Opera_FullScreen.png]
    (/assets/uploads/files/1521337755586-opera_fullscreen-resized.png) 0_1521337840264_Opera_FullScreen_wBar.png

  • Hi @michaelbix,

    The solution let itself be known. Opera in "Full Screen" is different than an individual page in full screen. The menu bar at the top disappears and there is no pathway back to other applications, let alone other open windows in Opera.

    I don't know which version of macOS you use, but as far as I can see every application on macOS works exactly like that. The menu bar is 'floating', you can make it reappear by hovering your mouse at the top of the screen. You can use the menu to switch to different windows. The same is true for the dock, it appears when you hover your mouse at the bottom of the screen, and it offers a path back to other applications.

  • Thanks, Avi. I'm using a supported OS but truth-be-told, I never "hide" menus or mess around with the more cosmetic side of OS tricks. I'm a low-dazzle grunt worker in the audio & visual design trenches, and I have no use for most of the OS bling... so can be completely thrown by "features" that other people take for granted. I was hoping someone would say - "Hey, did you try xxxx yet?" and throw some really OBVIOUS (to everyone else) trick at me which I don't know about because I never use it. I don't do the menu bar trick... so just like I defaulted to full-screen by accident; I discovered the solution by accident.

    This thread can be closed. Solution found.