Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

New Opera developer 51

  • WebGL is broken on Opera Dev build 51.0.2809.0?

    opera://gpu from 51.0.2809.0
    video works, but crash and broken WebGL (GL_EXTENSIONS is empty)

    opera://gpu from 51.0.2781.0 (no problem)

    OS: Siduction (based on Debian/sid) Xfce

  • Hi @alexs, reading the information from the first link, you can see, that the Opera #2809 uses Google's SwiftShader driver, which means there's no hardware acceleration at all - that explains, why you experience now "low frame rate". In the previous build #2781 you used Nvidia driver for your GF9600 GT.

    Conclusion: most likely some update (probably forlibgl1-mesa-glxpackage) overwritten installation files of the Nvidia driver. If that is the case, you can try to reinstall the driver, and check if this fixes the problem.

  • hi @l33t4opera, i don't found the notice for Google's SwiftShader driver (forum, blog?) but…

    • My OS Siduction (Debian/sid) is perfectly fine with the nvidia-legacy-340xx driver.
    • Opera is a Browser not a operating system, right?
    • I reinstall all Nvidia compenents with restart (problem still exists)
    • I now switch to Opera stable with Chrome security fixes…
    • I will return to Opera Developer when the Opera developers internal testing the linux builds before public this.


  • Hi @alexs, the "SwiftShader" is mentioned in your first link above - lines 55-56.

    Are you sure, that the driver works fine? Please call the following command in the console: lsmod | grep nvi, does it display, that the "nvidia" driver is loaded?

    Please also run: glxinfo | grep dir, and check if it says "direct rendering: Yes". If it says "Yes", then there's a problem with enabling the acceleration in the browser.
    Launch the Opera, go to Settings > Browser > System, and see if the "Use hardware acceleration when available" is enabled. If it is, and the acceleration is still "unavailable" underopera:gpu, run the Opera with the switch as follow: /usr/bin/opera-developer --ignore-gpu-blacklist, and see if this helps.

  • Hi @l33t4opera

    $ lsmod | grep nvidia
    nvidia              10559488  43
    drm                   360448  3 nvidia
    i2c_core               57344  4 nvidia,i2c_i801,psmouse,drm
    $ glxinfo | grep direct
    direct rendering: Yes
        GL_EXT_depth_bounds_test, GL_EXT_direct_state_access,
        GL_EXT_depth_bounds_test, GL_EXT_direct_state_access,
    $ grep glx /var/log/Xorg.0.log 
    [    35.598] (II) LoadModule: "glx"
    [    35.647] (II) Loading /usr/lib/xorg/modules/linux/
    [    38.115] (II) Module glx: vendor="NVIDIA Corporation"

    In browser settings the Hardware acceleration was enable.
    The command line option did not help.

    No problem with:
    Opera Dev

    And yes, i testing with new profile.

  • Just a note to mention that the latest build still will (eventually) insert about 10 branded Speed Dials and will (eventually) unset your default search engine back to Google's.

  • @alexs @l33t4opera Hi. No issues for me on AMD GPU with mesa and even with proprietary driver.
    But in your case, from what I see in your log, you have "WebGL2: Software only, hardware acceleration unavailable".

    So this mean that Opera not use HW for WebGL2. Maybe this is your problem because your previous build have "WebGL2: Hardware accelerated"

    So, try go to opera:flags and enable this flag - Override software rendering list. Restart browser and check again.

  • @angrypenguin said in New Opera developer 51:

    So, try go to opera:flags and enable this flag - Override software rendering list. Restart browser and check again.

    Hi @angrypenguin thanks for the tip, but there not help.
    And i have previously tested with command line option.
    opera-developer --ignore-gpu-blacklist

    I have no more idea.
    What is the significant modify difference (program code) between Opera 51.0.2796.0 and 51.0.2809.0?

  • Once in a while, including in the latest build, extensions are all silently disabled. Not sure what triggers this, or why it would ever do it silently, but whatever it is, it's too sensitive.

  • Hi

    Since updated to version 51.x.xxxx.x. everytime i start opera-developer it take forever to load ....

    Starting opera-developer from terminal, this is what i get

    [0107/] Invalid pattern
    [0107/] Invalid pattern
    [0107/] Invalid pattern
    [0107/] Failed to launch GPU process.
    [0107/] Lost UI shared context.

    The same patern apply to machine running nvidia or radeon.

    btw this is on linux arch installs

  • @loup001

    Corrupted profile probably, just rename it - if not done it yet -.

    Windows 10 (x64) | Anniversary Update
    Opera Stable · Beta · Developer

    Opera Test profile | Opera Reset / Back up Linux · Mac · Win

  • @zalex108

    Thank for the reply.

    As you suggested, i renamed my old profile to (~/.config/badopera-developer).
    Booted opera-developer ( which created a new ~/.config/opera-developer) and still get the delay with similar terminal output.

    [0107/] Failed to launch GPU process.
    [0107/] Lost UI shared context.

  • Then,
    Try posting on the blog and link to here, maybe the are more cases.

  • @loup001 Try starting Opera with the command --disable-gpu.

  • @leocg

    Thank's, leo and @zalex108

    The --disable-gpu solution on top of a new profile work's. 👍
    No more start delay. I still get crash in terminal output, but it does not slow down the startup.

    opera-developer --disable-gpu --private
    [0107/] Lost UI shared context.
    [0107/] Connection InterfaceProviderSpec prevented service: content_renderer from binding interface: blink::mojom::ReportingServiceProxy exposed by: content_browser
    [0107/] Connection InterfaceProviderSpec prevented service: content_renderer from binding interface: blink::mojom::ReportingServiceProxy exposed by: content_browser

  • @loup001
    Do you have NVIDIA, if so, can you check on opera:gpu if the hardware support is enabled?
    And how does the site work for you or very slow?

    With me the GPU support Opera Developer 51.0.2809.0 is corrupt (see my posting above).
    My result from opera:gpu: Opera_51.0.2809.0_gpu.pdf

    OS: Siduction 64bit, NVIDIA 9600 GT (nvidia-legacy-340xx-driver)

  • With Opera developer 51.0.2830 works gpu, all my issues from above have been fixed. 🙂

  • Also, there is a Flag to override blacklisted GPU's.

  • New update - Opera developer 51.0.2830.0 ;-)

    The change log, and the announcement.

    Import bookmarks added in bookmarks manager

    To make the Bookmarks Manager an entry point for all bookmarks actions, we’ve added imported bookmarks as a single folder there, together with exported bookmarks available in the expandable menu. All bookmarks imported from other web browsers will be filed in this folder.

    Ad blocker improvements

    Since we’ve released our native ad blocking feature, we’re still working to improve it. Last week, we added the anti-Bitcoin mining tool as one of the features of our ad-blocker.

    With string matching algorithm improvements, our tests have shown up to 13% average performance increase.

    Allow all sites to use Flash

    Today’s developer update offers now an option to allow Flash to run on all sites without request. By default, Opera requires sites to ask first, before allowing them to run Flash.

    If you want to allow all sites to run Flash without prior request, go to Settings (Preferences on macOS) > Websites > Flash.

    Other highlights:
    Opera for Mac now supports AppleScript, allowing you to create snippets for Alfred, or automate your workflow easily.
    HiDPI improvments.

    Chromium has been updated to version 64.0.3282.15.

    ☕   :spock-hand:   🍺

Log in to reply