Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

New Opera developer 51

  • New update - Opera developer 51.0.2809.0 ;-)

    The change log, and the announcement.

     
    "To start off this week, we have an update for Opera developer 51, with two new features. The first is a workflow improvement, to quickly scroll to the top web page with just a click on the tab. Second, your active desktop wallpaper can now seamlessly blend into Opera as your start page wallpaper. Finally, the video pop-out button received a new design.

    Further below you will find notes about other changes and fixes. Enjoy!

     
    Desktop wallpaper in Opera

    As you welcomed Opera Neon’s concept of a start page, that uses your desktop wallpaper as its background with such enthusiasm, we were compelled to introduce it in our browser today.

    Setting your desktop background as Opera’s wallpaper is as easy as adding your own theme from your system’s library. Head to the "Easy Setup" menu from the start page, and click the wallpaper option with the blue “Desktop” label across it.

     

     
    Scroll to the top

    We all have read, and scrolled through an endless pit of web content, such as our Facebook, or Twitter feeds, or a busy discussion board on Reddit. These kind of pages leave us with a long climb back to the top! It’s then another long descent down to continue where we were.

    In today’s developer update, simple click on the tab will return you to the top of the page, and second click will jump back to where you were before. This boomerang-like action is handy way to quickly bounce between your current spot, and the top of the page, while preventing you from burning out your scroll wheel, or trackpad.

     

     
    New style of video detach button

    Opera has undergone some stylistic touch ups in the past year, and now the video pop-out button receive a new look as well. You will find the new design in today’s update."

    ☕   :spock-hand:   🍺

  • Hi @alexs, you can try to use the latestopera-developer-ffmpeg-codecspackage (64.0.3278.0) from the Herecura's repo, without using any command line switches.

    Download it, navigate to the Opera's installation root, and make a new subfolder lib_extra, extract the libffmpeg.so file from the archive to this folder ;-)

  • Thanks @l33t4opera, this methods works. 👍
    But Opera needs longer to start…

    I save the libffmpeg.so to ~/.local/lib/opera-developer/libffmpeg.so with Symlink to /usr/lib/x86_64-linux-gnu/opera-developer/lib_extra/libffmpeg.so

    ln -s /home/user/.local/lib/opera-developer/libffmpeg.so /usr/lib/x86_64-linux-gnu/opera-developer/lib_extra/libffmpeg.so
    

    But I hope there is somewhere a public explanation for all how to integrate the customized libffmpeg.so (via script).

  • I now downgrade to 51.0.2781.0

    On http://slither.io i have very a very low frame rate with new Opera Developer.

  • WebGL is broken on Opera Dev build 51.0.2809.0?

    opera://gpu from 51.0.2809.0
    video works, but crash and broken WebGL (GL_EXTENSIONS is empty)
    https://paste.debian.net/hidden/820d5fb0/

    opera://gpu from 51.0.2781.0 (no problem)
    https://paste.debian.net/hidden/71878d70/

    OS: Siduction (based on Debian/sid) Xfce

  • Hi @alexs, reading the information from the first link, you can see, that the Opera #2809 uses Google's SwiftShader driver, which means there's no hardware acceleration at all - that explains, why you experience now "low frame rate". In the previous build #2781 you used Nvidia driver for your GF9600 GT.

    Conclusion: most likely some update (probably forlibgl1-mesa-glxpackage) overwritten installation files of the Nvidia driver. If that is the case, you can try to reinstall the driver, and check if this fixes the problem.

  • hi @l33t4opera, i don't found the notice for Google's SwiftShader driver (forum, blog?) but…

    • My OS Siduction (Debian/sid) is perfectly fine with the nvidia-legacy-340xx driver.
    • Opera is a Browser not a operating system, right?
    • I reinstall all Nvidia compenents with restart (problem still exists)
    • I now switch to Opera stable with Chrome security fixes…
    • I will return to Opera Developer when the Opera developers internal testing the linux builds before public this.

    Alexs

  • Hi @alexs, the "SwiftShader" is mentioned in your first link above - lines 55-56.

    Are you sure, that the driver works fine? Please call the following command in the console: lsmod | grep nvi, does it display, that the "nvidia" driver is loaded?

    Please also run: glxinfo | grep dir, and check if it says "direct rendering: Yes". If it says "Yes", then there's a problem with enabling the acceleration in the browser.
    Launch the Opera, go to Settings > Browser > System, and see if the "Use hardware acceleration when available" is enabled. If it is, and the acceleration is still "unavailable" underopera:gpu, run the Opera with the switch as follow: /usr/bin/opera-developer --ignore-gpu-blacklist, and see if this helps.

  • Hi @l33t4opera

    $ lsmod | grep nvidia
    nvidia              10559488  43
    drm                   360448  3 nvidia
    i2c_core               57344  4 nvidia,i2c_i801,psmouse,drm
    
    $ glxinfo | grep direct
    direct rendering: Yes
        GL_EXT_depth_bounds_test, GL_EXT_direct_state_access,
        GL_EXT_depth_bounds_test, GL_EXT_direct_state_access,
    
    $ grep glx /var/log/Xorg.0.log 
    [    35.598] (II) LoadModule: "glx"
    [    35.647] (II) Loading /usr/lib/xorg/modules/linux/libglx.so
    [    38.115] (II) Module glx: vendor="NVIDIA Corporation"
    

    In browser settings the Hardware acceleration was enable.
    The command line option did not help.

    No problem with:
    Opera Dev
    51.0.2781.0
    51.0.2796.0
    broken:
    51.0.2802.0
    51.0.2809.0

    And yes, i testing with new profile.

  • Just a note to mention that the latest build still will (eventually) insert about 10 branded Speed Dials and will (eventually) unset your default search engine back to Google's.

  • @alexs @l33t4opera Hi. No issues for me on AMD GPU with mesa and even with proprietary driver.
    But in your case, from what I see in your log, you have "WebGL2: Software only, hardware acceleration unavailable".

    So this mean that Opera not use HW for WebGL2. Maybe this is your problem because your previous build have "WebGL2: Hardware accelerated"

    So, try go to opera:flags and enable this flag - Override software rendering list. Restart browser and check again.

  • @angrypenguin said in New Opera developer 51:

    So, try go to opera:flags and enable this flag - Override software rendering list. Restart browser and check again.

    Hi @angrypenguin thanks for the tip, but there not help.
    And i have previously tested with command line option.
    opera-developer --ignore-gpu-blacklist

    I have no more idea.
    What is the significant modify difference (program code) between Opera 51.0.2796.0 and 51.0.2809.0?

  • Once in a while, including in the latest build, extensions are all silently disabled. Not sure what triggers this, or why it would ever do it silently, but whatever it is, it's too sensitive.

  • Hi

    Since updated to version 51.x.xxxx.x. everytime i start opera-developer it take forever to load ....

    Starting opera-developer from terminal, this is what i get

    opera-developer
    [0107/185530.099025:ERROR:blacklist.cc(190)] Invalid pattern
    [0107/185530.107172:ERROR:blacklist.cc(190)] Invalid pattern
    [0107/185530.139685:ERROR:blacklist.cc(190)] Invalid pattern
    CrashID=227db8b2-09e0-49de-99bc-97e382180107
    CrashID=a71222f0-7cd6-4bf7-bf0c-e421e2180107
    CrashID=bcbcbcec-6bde-4f5d-9800-484862180107
    CrashID=ebc6dd7f-cc9a-47a1-a661-6e5202180107
    CrashID=0a3e0397-5b0b-4374-8802-94d0c2180107
    CrashID=aebe3c1c-15eb-4973-b2c7-0fb0f2180107
    CrashID=f6046e36-4a3c-4732-9cda-195872180107
    CrashID=92facea7-097b-4fdf-9c8a-d5c782180107
    CrashID=ea845336-c637-46b7-ac97-131b92180107
    CrashID=05727b89-f43c-4d09-8c7a-657b62180107
    CrashID=7f62d262-721f-4864-b78c-4acb82180107
    CrashID=80ff3f0b-e9b6-4a8b-bdbf-fb9102180107
    CrashID=ac1b2d55-f54e-4c36-b9db-14d872180107
    CrashID=be1b7876-359f-42bc-966f-db10f2180107
    CrashID=34c41fd7-7b50-4f66-b981-f2bce2180107
    [0107/185603.993473:ERROR:browser_gpu_channel_host_factory.cc(120)] Failed to launch GPU process.
    [0107/185603.993734:ERROR:gpu_process_transport_factory.cc(1008)] Lost UI shared context.
    CrashID=1268b991-7371-4679-b829-7a8392180107

    The same patern apply to machine running nvidia or radeon.

    btw this is on linux arch installs

  • @loup001

    Corrupted profile probably, just rename it - if not done it yet -.


    Windows 10 (x64) | Anniversary Update
    Opera Stable · Beta · Developer

    Opera Test profile | Opera Reset / Back up Linux · Mac · Win

  • @zalex108

    Thank for the reply.

    As you suggested, i renamed my old profile to (~/.config/badopera-developer).
    Booted opera-developer ( which created a new ~/.config/opera-developer) and still get the delay with similar terminal output.

    opera-developer
    CrashID=9d16b9fc-1248-4877-a9c5-1d6ba2180108
    CrashID=e03913d7-c4f4-4564-b378-5e0a82180108
    CrashID=b7c9aa19-c29d-4dd4-95a3-36eb92180108
    CrashID=7fe5dfee-cc5f-446a-bd3f-249a22180108
    CrashID=bc4992c6-208d-41d0-a75b-f2cfc2180108
    CrashID=3662e7d1-5329-4859-ba78-2ead62180108
    CrashID=ae9eb5f0-6057-493d-9733-8a4912180108
    CrashID=67ec217c-85f3-43d4-8427-9d0f82180108
    CrashID=ccbd2341-b53c-45d7-a582-1c96d2180108
    CrashID=4c37ca94-65a5-4320-b9da-8e7e22180108
    CrashID=69f1e4c4-f804-4871-9cea-455d52180108
    CrashID=7bfe773c-3d15-40fd-ad37-2aacd2180108
    CrashID=a8982c06-d617-4f0c-9ab3-164b72180108
    CrashID=ae7a3431-fbcf-4e44-a293-c1cac2180108
    CrashID=0cd8e29f-ebf1-4021-9f76-9983b2180108
    [0107/214211.760561:ERROR:browser_gpu_channel_host_factory.cc(120)] Failed to launch GPU process.
    [0107/214211.760858:ERROR:gpu_process_transport_factory.cc(1008)] Lost UI shared context.
    CrashID=3c973a6b-e638-4940-9e19-e32fc2180108

  • Then,
    Try posting on the blog and link to here, maybe the are more cases.

  • @loup001 Try starting Opera with the command --disable-gpu.

  • @leocg

    Thank's, leo and @zalex108

    The --disable-gpu solution on top of a new profile work's. 👍
    No more start delay. I still get crash in terminal output, but it does not slow down the startup.

    opera-developer --disable-gpu --private
    [0107/225356.789658:ERROR:gpu_process_transport_factory.cc(1008)] Lost UI shared context.
    CrashID=d69af12e-6552-4299-a188-179642180108
    CrashID=6d6c8320-376b-4f2c-9305-ce8862180108
    CrashID=c5046be3-5898-4a4e-9985-327402180108
    CrashID=74a78e8b-94a0-429a-b197-a08f12180108
    CrashID=63944831-eb64-46bf-9885-dd0c12180108
    CrashID=eb13e6c3-c0d5-4f5e-8f06-5ea582180108
    CrashID=608f1fd3-8bc4-469f-8e94-101cf2180108
    CrashID=b0b0360d-e4d9-4e44-bd2a-38f6f2180108
    [0107/225515.338250:ERROR:service_manager.cc(158)] Connection InterfaceProviderSpec prevented service: content_renderer from binding interface: blink::mojom::ReportingServiceProxy exposed by: content_browser
    [0107/225515.338375:ERROR:service_manager.cc(158)] Connection InterfaceProviderSpec prevented service: content_renderer from binding interface: blink::mojom::ReportingServiceProxy exposed by: content_browser

  • @loup001
    Do you have NVIDIA, if so, can you check on opera:gpu if the hardware support is enabled?
    And how does the http://slither.io site work for you or very slow?

    With me the GPU support Opera Developer 51.0.2809.0 is corrupt (see my posting above).
    My result from opera:gpu: Opera_51.0.2809.0_gpu.pdf

    OS: Siduction 64bit, NVIDIA 9600 GT (nvidia-legacy-340xx-driver)

Log in to reply