O menu missing for ElementaryOS Loki

  • Yesterday my ElementaryOS Loki laptop picked up the new version of Opera, v49.0.2725.34. I could see that the O menu was missing but assumed the menu feature must be somewhere else but after digging around the web I discovered that it should now be at the top of the sidebar; The trouble is that it's simply not there. The top of the (where the O menu should be) is empty and not clickable. All the other sidebar menu items appear to be showing correctly and in their correct place. I've tried doing a complete uninstall and reinstall to no avail. My second laptop that also runs Loki has exactly the same issue and so this isn't unique to the machine. I've also installed Opera from scratch on an UbuntuGnome VM (Opera wasn't on it before) and on that the O menu is present. Is anyone else experiencing this?

  • This happens on some Linux versions; tapping the Alt key should display the menu. Or disabling the sidebar should allow the button to display.

  • Sadly neither of those actions have any effect :(

  • What desktop do you use on ElementaryOS?

  • Elementary os uses its own desktop enviroment called pantheon, which is a fork of gnome 3.

  • I can confirm this on Elementary Loki. The problem has existed in the beta versions since 49 also. The current developer version of 50 has the same problem.

    I had to find version 48 in order to get the menu button back. I'll be keeping version 48 local until I see it repaired in the developer versions.

    wget https://download3.operacdn.com/pub/opera/desktop/48.0.2685.32/linux/opera-stable_48.0.2685.32_amd64.deb

  • I've had the same problem on Elementary OS with any version past 48, including beta and developer versions. Version 48 can be had from the ftp site. I'll stay there until I see it fixed through the developer version.

  • Hi guys, @robbooker, @minuteman, you can try to run the Opera with the switch as follows/usr/bin/opera --show-opera-menu.
    If it doesn't work, you can also try XDG_CURRENT_DESKTOP=GNOME /usr/bin/opera.

  • Hi @l33t4opera Using --show-opera-menu has worked for me :) Thanks! I've updated my opera.desktop with the new param. I guess us ElementaryOS users just have to hope that there's a permanent fix in v50

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.