:tools: Scheduled maintenance

Heads up! Downtime for the Forums, related to the NodeBB upgrade, is planned for Thursday, November 23, starting from 10:00 UTC.
Please make sure to finish all your posts before this time. The downtime should only last for a few minutes.

No History at All!

  • When I click on the Show All History, I get a window with absolutely nothing in it, as if I had just erased my browsing history, which I haven't...

  • @stevencee What version do you use?
    I see this too in Opera 50.0.2759.0 (Edition developer, Mac OS X 10.11.6 64-bit), just not only History, but also on Extensions, Speed Dial, Personal News, and Downloads.

    Preferences is showing up normally, also most internal URLs (like opera://gpu/, opera://flags/, opera://dns/ and so on) works. Using the location bar, you still can search history and bookmarks.

    While this surely has been reported, i'm gonna send a detailed bug report (if neccessary).

  • After further research, i noticed that the issue most likely was because of some enabled flags (opera://flags/).
    I reverted some of the flags i changed in earlier builds, and restarted Opera. Now everything, including history, works again.
    So, check if you have enabled any flags, and either revert all of them back to default, or do it by trial and error.

  • @deluxive I'm using the newest one: 49.0.2725.39, and it's still not showing any history, nor does it want to open any of the previously open tabs & windows, they're there, but all are blank, with a "ran out of memory" message, although I have plenty of memory remaining! As for the flags, I'm not even sure what they are or do, so I haven't changed any of their settings, but I'll check and see if any are enabled, thanks.

  • @deluxive I began disabling each one manually, until I realized there were so many. So I instead just hit the Reset All to Default, then relaunched, but still no history is showing, and it won't even load all the windows and tabs, then crashes.... I don't know what's wrong with it...

  • I realized that MacOS has no offline installer, you may try the default one and reinstall upon your actual installation, perhaps it fixes the problem.


    Windows 10 (x64) | Anniversary Update
    Opera Stable · Beta · Developer

    Test profile | Back up Linux · Mac · Win

  • @zalex108 You mean reinstall this version of Opera? Maybe I'll try that...

  • @stevencee

    Yes, but without deleting the current one, just like if was a manual update but with the same version.


    Windows 10 (x64) | Anniversary Update
    Opera Stable · Beta · Developer

    Test profile | Back up Linux · Mac · Win

  • @zalex108 I did it, and still no history.... Plus, it seems Opera doesn't like opening or shutting down, as it will stall forever.... and it'll run up over 8GBs of RAM..... Not sure if I can keep using it, doing all these things.

  • @stevencee Try renaming the 'History' file located in Opera's profile directory.

    Also try disabling hardware acceleration in settings.

  • @stevencee said in No History at All!:

    @zalex108 I did it, and still no history.... Plus, it seems Opera doesn't like opening or shutting down, as it will stall forever.... and it'll run up over 8GBs of RAM..... Not sure if I can keep using it, doing all these things.

    I remember that behavior sometime ago in Opera Presto but didn't know in the Chromium version.

    Maybe there is an extensions keeping it alive.


    Windows 10 (x64) | Anniversary Update
    Opera Stable · Beta · Developer

    Test profile | Back up Linux · Mac · Win

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.