Three windows buttons gone

  • Hello there!

    I have installed Opera on Kali Linux. However, I have noticed that when I maximise Opera's screen, the three window buttons on the right upper corner are gone. I can't minimise Opera any more and also can't change Opera's screen size.

    This is a problem that really only concerns Opera, because with all other applications, I don't have this problem.

    My question is: is there a way to get those three buttons back when Opera is maximised?

    If not, then I hope that this bug will be fixed soon, because it's really irritating.

  • What desktop enviroment does kali have (gnome/kde/xfce/something else)?

  • Maximize, or fullscreen mode? Fullscreen mode is supposed to remove everything, while Maximize should have a title bar and window decorations.

  • I use XFCE, and all buttons are gone, when window is Maximized. I do not want to go with mouse acros whole screen to taskbar to minimize it, I do not want to go to Menu and click Exit. What's wrong with UI designers these days. Removing basic functionalities which works for decades.

  • This is weird, because opera, unlike chrome or chromium, does not have its own csd (client side decorations), so it relies on the window manager of the desktop enviroment for the minimise, maximise, close functions.
    What window manager are you using?

    Needless to say I have no problem here (debian testing x64 with openbox).

  • I have old Fedora 22 in VM, not updating. Only Opera is updating there. Nice couple of versions before, there were all buttons. After some time, only X was visible. Now, nothing is visible. I installed in second VM Fedora 26, complete default XFCE, with latest Opera, and now, only X is visible when maximized.

  • hmm have u changed flags? there's some flag regarding the title bar...

  • No, pure default installation. I didn't found any flag regarding titlebar or buttons.

  • Xubuntu 16.04 32 bit. Also have no buttons in the upper corner when Opera is maximized. I only have Tab menu here.

  • They do not want us to use their browser...

  • Hi guys, @sencor90, @pindos, perhaps a little late reply, but as they say "better late than never" ;-)

    You can make it visible again, just follow the steps: go to Settings -> Window Manager Tweaks > Accessibility, and uncheck the checkbox on the left of "Hide frame of windows when maximized".

    Window Manager Tweaks - Accessibility

  • @l33t4opera
    I had the issue of a maximized Opera "fighting" not do be un-maximized or resized using latest LinuxMint (Cinnamon) – min | max/rest | close window decorations were visible, though. Using a swift mouse move it was possible to move the maximized Opera from one Screen to an adjacent, different sized monitor where it instantly maximized itself again. All those mouse interactions leading to flickering, by the way.

    I checked any of Cinnamon's "snap to *" settings but what did get me Opera restored was to save the session with V7 Session sidebar extension, closing Opera, deleting "Current Session" from the profile, and ultimately restoring the session from V7 Sessions.

    I guess, there is a bug – and perhaps it is the same the OP was suffering from.

  • @l33t4opera Ok, thank you. It's solution. But I have a small display (Asus EeePC). When I uncheck this checkbox, another titlebar appears. The visible area of browser decreases. 😞

  • Use the keyboard then.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.