:tools: Scheduled maintenance

Heads up! Downtime for the Forums, related to the NodeBB upgrade, is planned for Thursday, November 23, starting from 10:00 UTC.
Please make sure to finish all your posts before this time. The downtime should only last for a few minutes.

dont load inactive tabs

  • until opera 46 came out everything was ok but now its all broken because every tab is loading... could you please add an option so that inactive tabs wont load until selected?

    downside of every tab loading is:

    1. it takes much more RAM to load every tab
    2. it takes longer time
    3. puts constrain on HDD (i hear how it is in pain)
    4. uses more network traffic
    5. loads CPU

    what are the benefits?
    1)???

  • I totally agree. Having this middle ground setting of loading some pages at the discretion of the browser is not useful to me. It has all the drawbacks minato just mentioned above. I'd rather have the old classic behavior. It's not like loading a page takes that long and I'm not willing to wait 2 seconds if I go to a yet-not-loaded tab. But I do dislike having the browser use a lot of resources each time I open it. That makes me use another browser if I need to just quickly check an url.

    Furthermore, each time all these background pages are reloaded, their all come up in the history list, like if I really visited them right now, which was never my intention. It's like corrupting the browser's history, making pages be in the wrong date.

  • so when i start opera if active tab is a youtube video it doesnot play right away (video starts than it stops and buffers) because other tabs are loading and internet speed is not enough... can someone explain to me why is this a good thing that i dont have an option not to load other tabs until selected?

  • found nice link from 2012 https://opera.uservoice.com/forums/4259-general/suggestions/3366053-don-t-load-tabs-until-selected with some angry guy :D "I suggest you ...developers...just Fuck Off with this AUTOFUCKINGMATIC self-loading tabs issue!

    I bet you just sit there and laugh BIG TIME of us suckers who use this shitty Web-reader you created after you sniffed a few stripes!

    I even bet you don't use this shitty web-reader you're self, because of this problem, and use Madzilla Problemfox you too!

    What is your problem???

    Why don't you fix this issue???"

  • This is because the developers removed the #extended-lazy-session-loading flag since the 46 dev build appeared in May.

    It might be painful for us, but they (Opera team) seems to not listen.

    My work rely heavily on Opera and the usefulness of #extended-lazy-session-loading AKA "not load inactive tabs". So in the mean time, I recommend all of you to stick with Opera stable 45.0.2552.898 or Opera beta 45.0.2552.634 - these are the last versions that still have that flag working properly.

    If the next official Opera builds still missing this flag or any workaround, I may have to switch to another Blink-based browser completely.

  • With a 2Mbps line and ~30 permanently open tabs, this "new feature" causes me ~5 minutes of overloaded internet line after starting the browser.

    I can either re-introduce the coffe break which was used for slow computer starts in the past or I completely switch over to Vivaldi.

    It's up to you, Opera guys!

  • +1 Why would you even remove the #extended-lazy-session-loading flag?! Please bring it back!

  • Why would you even remove the #extended-lazy-session-loading flag?

    The answer is on flags page itself. :-)

  • Flags!! Huh!! Use switches!!

    https://peter.sh/experiments/chromium-command-line-switches/

    You have been warned.

  • Use switches!!

    And that switch would be...?

  • Please add "Don't load tabs until selected" functionality to options page.

  • Please add "Don't load tabs until selected" functionality to options page.

    You can use this extension to add this functionality.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.