Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

What is causing the busy circle when closing down the browser?

  • The circle at start is 10secs the close is 15secs
    sync is not enabled
    no tabs open
    system is a year old and fast very fast i7 12gb titan x the system is not the problem
    this does not do it on any other browser
    what do other people see.

    Are you using any third-party antivirus or internet security solutions? They may slow down closing files and they may not know about Opera profile folder and how to optimise its usage.

    I suppose your 'titan' system is based on good SSD drive(s)?

  • I'm seeing the same issue. It happens every time i close browser. It happens on my home PC as well as on my work laptop. It not happens with all other programs or browsers, only with Opera closing. Reproduced in 100% of cases with extensions or without, with several tabs open or without any tabs at all, with Opera account sync enabled and disabled as well. For experiment, I even uninstalled the my antivirus, and still blue circle is there when i close Opera.

  • I have this issue too, at start and closing. No other browser does that. Perhaps slimjet but 1 or 2 seconds, opera start 10 sec, closing 6 sec.

  • Completely uninstalled Opera (Registry and hidden folders included) and did a reinstall without addons but to no avail.

  • I guess it needs to be fixed so anything that you do will not make any difference.

  • Some few years ago, a 10sec delay wouldn't exist - on the background of an evergreen up to a minute loading pages.

    What's happening to you, people? What are you rushing for? Take a break for that 10sec, have a breathe.

  • I notice this with Opera, also, FWIW. I have Vivaldi, Chrome, Palemoon browsers on my system and they do no have this effect when closing them.

  • What's happening to you, people? What are you rushing for? Take a break for that 10sec, have a breathe.

    It´s not rushing, it´s to know why this only happens in opera

  • I have solved this vexing problem by trial and error. It's a right royal pain in the backside but I found a simple fix. Go into "settings" and the go to "browser" and then "system". There is an option for "hardware acceleration when available". Click on that choice and your spinning pointer goes away. Hooray!

  • I have Hardware Acceleration checked. I still get the spinning circle for about three seconds.

    joshl ... It's not a matter of being impatient. People are simply asking, what is going on in the background.
    Perhaps a developer could answer this question.

Log in to reply