Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Google Calendar won't let go.

  • Whenever I visit Google calendar, it puts up a message under the bookmark bar:
    "Allow calendar.google.com to open all web calendar links?"

    Issue #1: There is a circled i to the left of the question which seems to indicate one should click it for more information, though clicking it doesn't do anything, is that normal?

    Worse is issue #2: There are only two options... close (the x on the left), and allow (the button on the right). There is no way to say "no, I don't want this." Meaning that, unless you click "allow," this alert will come up again every single time you go the calendar.

    Even worse is issue #3: If I ignore it, once I subsequently navigate to some other window (say, by typing some other URL or clicking a link in the bookmark bar), the google alert persists through to the next site! So as I go from site to site, once I visit google calendar, this alert will stay in my window forever, until I acknowledge it (with an "allow" or a close).

  • I discovered that this is partially solved by going to

    Settings-->Privacy & Security-->Handlers

    and selecting

    "Do not allow any site to handle protocols"

    This took me a while to discover, because I did not know what a "handler" was.

    There does not appear to be a way to turn it off for one thing without turning it off for everything, though. (Nor does it explain the "information" icon that doesn't appear to do anything.)

  • Agreed. There should be a way to dismiss a handler request for good without effecting other handlers.

  • Post about it in the Suggestion box forum to get someone's attention (though they may not reply, they will read it).

  • re: "Post about it in the Suggestion box forum to get someone's attention (though they may not reply, they will read it)."

    They don't read the stuff in this forum? That would kind of defeat the purpose of reporting bugs here!

  • re: "Post about it in the Suggestion box forum to get someone's attention (though they may not reply, they will read it)."
    They don't read the stuff in this forum? That would kind of defeat the purpose of reporting bugs here!

    They read it, but do not reply in Suggestion box.

  • @curious273 It seems that we are expected to report bugs here. It may still be helpful to post to this forum for our brothers and sisters who could be experiencing the same problem. It would also be nice to find a workaround in the meantime. Sometimes, we may find that it is not a bug at all.

  • Zalex, your answer seems like a non-sequitur, I think maybe you missed the distinction I was making between this forum and the "suggestion box forum", whatever/wherever that is... i.e. I was being told I should post somewhere else rather than here if I expect someone from Opera to see it.

    Tufazay, thanks for that link, I was unfamiliar with that as well.

  • your answer seems like a non-sequitur, I think maybe you missed the distinction I was making between this forum and the "suggestion box forum", whatever/wherever that is... i.e. I was being told I should post somewhere else rather than here if I expect someone from Opera to see it.

    The Suggestion box is here but it is another SubForum in General Topics.
    Opera employees read Suggestion box posts but do not reply.
    They mostly reply in Mac's subforum. :lol:

    I though you knew about subforums but didn't read entirely the Sgunhouse's post. 😉

  • @curious273 said in Google Calendar won't let go.:

    Worse is issue #2: There are only two options... close (the x on the left), and allow (the button on the right). There is no way to say "no, I don't want this." Meaning that, unless you click "allow," this alert will come up again every single time you go the calendar.

    Just in case anyone else runs across this because they're having the same problem (like I just was), there is a way to fix this for a particular site yourself but it does require a fair bit of technical knowledge. If you don't know what a condensed JSON file is and how to edit one safely, you should just disable the option altogether as mentioned above.

    If you do know what a condensed JSON file is and how to edit one, here's the rough outline. I'm intentionally leaving out a lot of details just in case someone is tempted to try this without knowing what they're doing and potentially corrupting their entire profile in the process.

    1. Go to the site that's asking if you want to "Allow" it to be a protocol handler and click "Allow". I know this seems backwards but bear with me.
    2. Completely close Opera. Otherwise the changes you're about to make will get lost.
    3. Open up the "Preferences" file in your Opera profile directory. (preferably in an editor than can expand it to make it more readable. I used Atom with the pretty-json package.)
    4. Search for "registered_protocol_handlers" and look for the one you just registered.
    5. You should see the handler you just selected listed in that array. It should have 4 properties: default, last_modified, protocol, and url. Delete "default" (including the value and the trailing comma)
    6. If you want to be extra thorough, move the entire block for that particular handler from the registered_protocol_handlers array into the ignored_protocol_handlers one. If you don't know what that means just skip this step.
    7. Save the file and start Opera back up. Navigate to the site in question and you should find that it no longer prompts you. Note that when you accepted the handler earlier, you may have updated your system handler preferences as well (for mailto links for example). Remember to change that back after you're done, otherwise those links will still call Opera but it won't know what to do with them.
  • Tip: Never reply to an one year old topic.

Locked