The browser renders accentuated characters+ weird

  • I'm Chilean, meaning that my first language is Spanish. I'm using Opera 41; the text is already a bit blurry in general, but I can deal. What's really bothering me is how characters such as á é í ó ú Ñ ñ look in the browser. I've noticed it happens with the ç character too, but we don't use that one.

    It's like the letter-spacing of those specific characters gets screwed up. http://imgur.com/a/MBMZi

    (Note, the highlight in the words "esté usando" is there because I DID type it with a space between the words, when I select the text it's there, but it looks like it's not.)

    I realized too that this doesn't happen with all text in Opera, it happens with just the random paragraph text font that Opera uses (And yes, I've tried to font configuration a thousand times, doesn't make a single difference).

    All these characters conflate with the one immediately next to them (Including dots and commas) and it's really upsetting to me. I've tried to find a way to solve it but I've come empty handed.

  • Any changes if you disable hardware acceleration?

  • This happens only on some specific sites, correct? I have seen similar report lately - there likely was some corrupted (or otherwise nonstandard) font (Helvetica) installed; problem appeared only on sites, using Helvetica as their default font.

    Using Opera "Inspect element" command you can find out, what exact font these garbled texts use.

  • @leocg I've tried that many times and no changes. :c

    @donq No, it happens everywhere but only with the regular "default" text of the website in question. Headers, for example, don't have this issue, neither does text with heavy CSS formatting.

    This is an example of how things look in my screen: http://imgur.com/a/nsmB7

  • I also use Spanish and it renders perfectly both in Opera 38 and 41. Here's a screenshot:

    The font family used is "Helvetica, Arial, sans-serif". If in the developer toolbar I uncheck that style, it reverts to Times New Roman, and it also displays as expected.

    I notice your font appears slightly bolder than mine, especially in the "Iniciar sesión" (Log in) button. Go to Settings (Ctrl-F12), type "fuentes" (fonts) and look for the option "Personalizar fuentes" (Customize fonts). There you will see which fonts are being used for each family. In my case, I have Times New Roman, Times New Roman, Arial and Consolas, and the size is 16.

    You may also try downloading a portable version of Opera, in order to have a clean independent instance of the browser, and see how it looks there.

    PS: I've reached 128 posts! Yay! So nerd! 😛 😄

  • @alobpreis I have no idea what I'm doing or how to apply the setting to everything at once? I have this problem in every website I go as long as it's not header text and such. I don't know what to do. Also I'd already tried playing with the font settings of the browser and it changed nothing.

  • I played around with the developer tools and (After screwing up quite a few things in a couple of pages), I reverted it all back to default. It only changed one page, not even every page of a single website, much less everything in the browser.

    I already had my fonts set to the same fonts and sizes as you, and played around with them too - no changes.

  • Well, another idea - have you using some extensions? I for example could make use of 'wrong' fonts almost everywhere, using StyleBot extension - it allows global styles to declare. It is possible that some other extension redefines styles as well, even if it doesn't explicitly state this.

  • Naeril, what I mentioned about the developer toolbar or only to debug the page, it won't make any permanent change to any page. I only wanted to know if you see the exact same fonts in both that toolbar and in Opera's font settings, to try to find where the issue lies. Can you confirm all this?

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.