[Solved]Address Bar Text Entry Broken with "Enable advanced keyboard shortcuts" enabled.

  • Noted this problem occurring for at least the last few weeks but only now found a config item that can be toggled to fix/reinstate the problem.

    Problem Description: When attempting to type a URL into the address-bar, various characters are unable to be typed because they've been mapped as short-cuts to features.

    Examples.

    Attempting to type www.anything.com fails because the "." character cannot be typed as part of an address.

    Attempting to type www.webservice.com/mywebservice?wsdl fails because the "?" character causes the in-page search to appear.

    Attempting to type a URL with certain numbers in fails because some numbers have been mapped to changing the zoom level of the current page.

    Solution: Go to the address below and ensure that the feature "Enable advanced keyboard shortcuts" is disabled. I did not previously enable this feature so it should probably be disabled by default to avoid this issue.

    opera://settings/?search=keyboard

    Additional Info: Currently on Opera Developer 41.x. Tested and confirmed fix while all extensions disabled to prove this was not extension related.

    Suggestion: At a minimum, if this is a useful feature in general, adding a check on the advanced keyboard shortcuts to ensure the keyboard focus is not in the address bar would probably be a good starting point.

  • Hi @broliant, the problem seems to be fixed in the latest Opera developer build - please have a look here, though there's an issue with the VPN feature 😉

  • Hi @l33t4opera,

    Yes - just updated to Opera Developer 41.0.2323.0 and it's fixed the problem for me. Thanks for letting me know!

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.