Same thing here. I too have been having this issue for the past few versions. Having to download the installer is not only an annoyance, it also defeats the purpose of having an updater in the browser. Please fix this.