Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Downloaded and installed Flash Player, but it still didn't work.

  • Thank you, leocg.

    In Settings > Websites > plugins, the selected option is "Run all plug-in content (recommended)"

    Under the entry "Adobe Flash Player (2)" in Opera > Developer > Plug-ins is("Disable" is a button, which means it is already enabled):

    Adobe Flash Player (2)
    Version: 18.0.0.114
    Shockwave Flash 18.0 r0
    Disable

    Name: Shockwave Flash
    Description: Shockwave Flash 18.0 r0
    Version: 18.0.0.114
    Location: C:\WINDOWS\system32\Macromed\Flash\pepflashplayer32_18_0_0_114.dll
    Type: PPAPI (out-of-process)
    MIME types:
    MIME type Description File extensions
    application/x-shockwave-flash Shockwave Flash .swf
    application/futuresplash FutureSplash Player .spl
    Disable

    Name: Shockwave Flash
    Description: Shockwave Flash 17.0 r0
    Version: 17,0,0,169
    Location: C:\WINDOWS\system32\Macromed\Flash\NPSWF32_17_0_0_169.dll
    Type: NPAPI
    MIME types:
    MIME type Description File extensions
    application/x-shockwave-flash Adobe Flash movie .swf
    application/futuresplash FutureSplash movie .spl
    Disable

  • If you disable the npapi flash, does it make any difference?

  • Yes, it does. I got a message saying "You haven't installed Flash Player. Click here to install it." (The original message was Chinese. I've translated it.) I'll click the "Here" link to install it. Thanks.

  • It worked at last. Thanks, leocg. Thank you, everyone.

  • how do u do this with a fresh install of 7 and opera and java because its picked up silverlight and flash but never finds java on my machine can someone just tell me where to add dir please 🙂 many thanks for any help guys

  • Java needs separate installs for 32 and 64-bit programs. So, if you installed the 64-bit version you will also need to install the 32-bit versions. Give that a shot.

  • Thank you ill try now

  • Question: I have both Opera 12 and 29 on Kubuntu 15.04 (x86_64; KDE). Flash works on Opera 12. But not on my new install of Opera 29 with the message "Adobe Flash Player is missing."
    I already have Restricted extras and Adobe Flash plug in installed in the Software centre. What else can I do? Thanks.

  • @ianp5a You need the PPAPI version for the new Opera. (pepperflashplugin-nonfree)

  • Oops I posted in the wrong area.

    Thanks I found pepperflashplugin-nonfree in the software manager, installed it and it all works OK.

Log in to reply