Lost keystrokes and mouse gestures

  • For a long time I'm using Opera with Ubuntu 12.04.5 (x86_64, compiz, cinnamon).
    Since opera-beta (29.0.1795.*) and opera-stable (29.0.1795.47) a nasty bug appeared.

    After approximately 1 hour of intense browser using (with JIRA, Google maps, etc) browser stops responding to mouse gestures. Even worse, keyboard strokes are not caught by Opera, too.
    When this happens all I can do is to restart Opera browser. Since it's happening quite often it breaks my workflow and needs to be fixed.

    Anyway, thanks for a great browser guys!
    -Nikola

  • I recommend upgrading to at least Ubuntu 14.04 LTS.

  • I don't find this is an acceptable solution, since this is platform I use for job and Ubuntu LTS upgrades are proven to be painful.

  • I have the same problem with windows 8.1.

    I haven't been able to pin it down, it seems somewhat random. I've encountered the problem in youtube and google search.
    Seemingly without anything out of ordinary happening, maybe opening a link and closing it, the mouse gestures and keystrokes stop working.
    Keyboard still works elsewhere normally and restarting opera fixes the problem. Sometimes the bug has appeared often in a row and then a day or two with nothing.

    I have logitech gaming software 8.50.281 installed for my mouse and keyboard.

  • @johnny47ns, can you tell us a bit more about the bug? Does it disappear if you close and re-open the tab (Ctrl+W, Ctrl+Shift+T)?

  • @avl I have a bit more info on this. This just happened again. I was on imgur, had been for hours and didn't do anything out of ordinary. I think the bug "activated" as I close the imgur tab, but I'm not 100% certain. I always notice it when I try to close a tab and the down-right mouse gesture only shows the context menu(right click).

    The mouse gestures and keystrokes seem to stop working only inside the opera window.
    I could still write to the address bar, but not on this comment box for example.
    Also all keycommands (like ctrl+w) stop working.

    Re-opening the tab does nothing and the problem persists on all tabs, but restarting opera fixes it.

  • I had had the same browser session open for ages(day or two) and had opened and closed tons of tabs during, I probably cleared browsing data multiple times too out of habit.
    Maybe it has something to do with long continous browsing sessions?
    I keep my browser open always and pretty much close it only when this bug appears.
    I was stupid and didn't check the memory allocations or anything in-depth, but I'll try to remember the next time the bug appears.

  • I experience the same issue since a month ago or so, on 3 computers, with Win7 and Win8.1 as well. After a longer period of time and lots of opened tabs, I simply cannot write to any text box on any tab, I also cannot refresh the page with F5, or search with F3 buttons, and the mouse gestures stop working as well. I tried to close as much page as possible, but it seems that only a restart of the Opera helps. There's no suspicious CPU over load, nor memory overload issue, and the only extension installed is AdBlock with CatBlock ( 🙂 ). Actually I tried to close the tab and reopen it, but Ctrl+W also not works. How can I help to solve this issue as it gets a bit uncomfortable for me? Thank you!

    Edit: as a remark, Ctrl+click to open link in a new tab still works!

  • Have the same issue on Windows 10, also before on Win 8.1. Pretty sure it can't be browser specific now. Confirmed mouse gestures stop working after a while of medium usage, keyboard shortcuts also stop, and things work again after restarting Opera. It seems to have the additional effect of disabling typing in official Opera forum comment boxes, though not sure if it was related.

    Keyboard shortcuts can be re-enabled without having to restart, just switching to another tab or clicking around fixes it.
    Gestures can also be re-enabled without having to restart, I just don't know how, clicking/typing around somehow fixed it for me, but only has worked the one time (but I'm 100% sure on that, cos it happened while I was typing this).

  • Same bug for me too, i hope that a fix is coming soon because i can't use opera for work anymore. I have notice that this bug occurs more often when i do a lot of quick and approximate mouse gesture (mainly the close tab gesture).

  • I have the exact same bug, only on linux so far though. I'm using Linux Mint 17.1 ('Rebecca') so I highly doubt that it's related to using an old Version of Ubuntu as the OP does.
    It's really annoying, especially since I've had this issue dozens of times now, but cannot reproduce when it happens. Restarting the browser just because of this is a bit annoying...

  • I don't have any new info on this, but just wanted to say that I haven't seen this behavious yet in the newest 33.0 build.
    Not usre if it's fixed, but I'll report if it happens again.

    How come there's no word from developers on this?

  • Same here (v 33.0.1990.58), after update to win10 I have it very often, it's more than annoying...
    I've switched off PDF plugin and try work without hardware acceleration, nothing helps.

  • After switching off mouse gesture, opera was working fine by whole day...

  • I haven't experienced this bug for a month at least, maybe two. Is it fixed?

  • Before update my WIN 8.1 to WIN 10, I didn't hear about it... now I can't use mouse gestures...

  • I haven't experienced this bug for a month at least, maybe two. Is it fixed?

    It's not fixed. It's present on windows.

  • I am able to back up this problem, although it does not necessarily occur after one hour. Unfortunately, I have not been able to figure out the exact cause. Meanwhile, I have gotten used to simply reopening the browser whenever the gestures stop responding.

    The bug applies to the current version of Opera (35.0.2066.37), although the issue has been present since forever. The following add-ons are in use:

    • µBlock
    • Download YouTube Videos as MP4
    • HTTPS Everywhere
    • Instant Translate
    • LastPass
    • Select like a Boss
  • Can you not post Windows issues in the Linux forum? You really think any Linux developer who reads this can help your issue?

    Thread closed, please post in the correct forum.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.