Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • Did a reinstall of Opera 12.17 today (x86, Win 8.1 x64). Since then, Windows CP isn't seeing Opera among the default browser choices or among the associations for for http, http, etc. It is seeing it for other types, though, such as jpeg, etc. Any idea how to fix this? Any Opera file in particular (from backup) that cues this ? Thanks,

  • Just use the settings in Windows to reset the file associations.

  • lando, please try reading my post again.

  • Before I uninstalled/rebooted/reinstalled Opera 12.17, Windows was detecting both 12 and Opera 29b. Since then, here are some screenshots that show neither version not being detected except 12 on the main (upper) file association list:

  • You can set file association manually in Windows. Don't use the control panel to do it though.

    Failing that you can try reinstalling Opera. Try running it as an admin and making sure you install it for all users though. Use a program like Revo Uninstaller to remove it first.

  • Lando, how does one set a file association for Opera manually in Windows when Windows is not recognizing the program as a choice.

    I did install for myself only this time, for the first time, because of an error that had arisen when trying to open bookmarks from a bookmark utility (Bookmark Buddy). The error was telling me to set as an individual user, so I decided to give it a try. Obviously, not the way to go.

  • Here's one of the two error messages that crops up every few weeks while opening a link in Bookmark Buddy that led me to try a single user setup: BB's developer can't figure it out, since it only occurs with Opera 12 and Opera webkit, not IE11 or FF3x.

  • Right click the file you which to change the association with and then click 'Open with...'. Once the menu has popped up make sure the checkbox is checked and click 'More Options'. Scroll to the very bottom of the list and click 'Look for another app on this PC'. Find the program you want to use manually.

  • If Windows is not recognizing Opera, then Open With doesn't show it and the link at the bottom of the popup is to MS store apps not other programs on the computer. I think there's a screenshot of that.

  • Have you installed it for all users?

  • Yeah, nah. You are incorrect. If you hit more options and then look for another app on this PC it will let you browser for any .exe file you want. I just tested it with Windows 8.1.