How to turn off auto update?

  • Comodo programme manager just flagged up that Opera had updated without my permission. This is not on. I do not wish Opera to update without my knowledge. Anyone know how set Opera for Windows to only update when I choose to? If this is not possible then it's bye bye Opera.

  • Block opera updater access to the Internet.

  • Thanks for your reply, please elaborate how you do this. There doesn't apear to be a setting in the menu for Opera.

  • There's no such thing in any menu or setting within the UI. You'll need to go to the pertinent file in your Opera profile folder and change its name or something.
    Am I right, geeks?

  • I don't know how to do this, but I was so disappointed after the recent changes to the speed dial that I decided to make a downgrade.

    So, after updating to ver. 28 I've still had the 27 folder there - I just had to edit the installation_status.xml file and replace the 28 build number with the 27 build number (must be same as the folder name) and now I'm back on 27!

    I've made a backup of the 27 folder in a zip archive, so that even if another auto-update erases it, I can always bring it back. I know it's not a solution (I'd like to know how to disable the auto update too!), but it's always some kind of a workaround - you can perform a downgrade every time the browser upgrades itself. :idea:

    Hope this helps somehow. And always remember to backup your files before you'll start to mess with them! :D

  • Asked and answered a couple of times a month over the past two years it seems.

    Look in your windows scheduled tasks. You'll find a task that looks like this:

    C:\Program Files (x86)\Opera\launcher.exe --scheduledautoupdate

    You can look at this through Control Panel, CCleaner, and/or Glary Utilities. Easy enough to disable or delete.

    But every time you manually update Opera, this entry will be back, so you will have to remember to go after it.

  • There's no such thing in any menu or setting within the UI. You'll need to go to the pertinent file in your Opera profile folder and change its name or something.
    Am I right, geeks?

    This is one of the possibilities.

  • Look in your windows scheduled tasks. You'll find a task that looks like this:
    C:\Program Files (x86)\Opera\launcher.exe --scheduledautoupdate

    There is no such entry there (or anything related to Opera). But I've installed the new Opera as a standalone application, maybe that's the reason?

  • I'm running W8.1. If you enter "schedule tasks" (without the inverted commas) into your search bar you should find the Opera auto update line there in the Task Sheduler. Double click on the Opera line and it will open a new box/window where you can remove it.

    kuhlmanck was almost there, I just found it has to be "schedule tasks" and not "scheduled tasks" for W8.1. I realise that may be different if your not using O/S W8.1

  • kuhlmanck was almost there, I just found it has to be "schedule tasks" and not "scheduled tasks" for W8.1. I realise that may be different if your not using O/S W8.1

    I'm on Windows 8.1 too and that's where I looked for it - in the Task Scheduler. There are schedules for other browsers (Maxthon and Chrome), as well as other programs, but nothing about Opera. I think it's due to the installation method that I've chosen (as a standalone app).

  • kuhlmanck was almost there, I just found it has to be "schedule tasks" and not "scheduled tasks" for W8.1. I realise that may be different if your not using O/S W8.1

    I'm on Windows 8.1 too and that's where I looked for it - in the Task Scheduler. There are schedules for other browsers (Maxthon and Chrome), as well as other programs, but nothing about Opera. I think it's due to the installation method that I've chosen (as a standalone app).

    Oops sorry I didn't pick up on that originally, yes that would make sense to me,

  • I think it can be done by blocking the update url..

    Locate the host file ("C:\Windows\System32\drivers\etc\hosts") and add the following line:
    127.0.0.1 autoupdate.geo.opera.com

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.