Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

opera dialog missing consonants, only "a" and "E" usually visible

  • FreeBSD v9 > v10. Dialogs on the UI are only partly visible during a recent shared library bump.
    For instance, I can see this as I type, but the title, of this post, is only
    a a a a a E a
    which may be the same number of those vowells within it. From here, as I type this, I cannot
    see the title which I just typed.
    Only occurs on some web pages (debian wiki VS gentoo wiki, for instance)
    And in about:config: the items to change are visible, but not the selections,

    Font >> one cannot see the old to change to a new, but can type it in without knowing
    if the spelling is correct, etc.

    If there is a term in about:config (specific item) which applies to the text in the
    Opera menu button, "Opera", as well as the text one types into the URL bar (as I type
    this, the url is showing as " a " ... then I could maybe change its color
    or font type and fix the issue.

    Thanks.

  • i'm not completely sure i understand what you mean. but if the problem is connected to some other issue with a shared library you may want to re-install that library.

  • We've seen this before with one of the *BSDs ... I think it was some sort of encoding issue, but don't recall. Until someone with more knowledge comes along, I just wanted to tell you it is not unknown or unique to you.

  • Problem was present in all v10 installs. v10 disk crashed.
    backed up using a v9 disk, first upgrading it to v10.
    v10 >> not upgrading the OPERA port but all its dependencies,
    afaik,
    default no-problem scenario working again
    [ v7 opera > v 12.16 opera > please restore Presto takk... ]
    as long as I do not "officially" attempt to install opera
    [the system does not see it as installed, but it is installed,
    maybe not converted properly in the v9 > v10 BSD pkg method change]

    tl;dr
    FIXED for now, on the primary disk, [ please restore PRESTO or
    all its features in Otter ... or even source the PRESTO so it can
    be forked. Even as shareware which is how I bought it in windows98
    v1 era... millions of more customers for the latter I surmise. ]

  • Freebsd revamped its ports' font structure this week. Reinstalls fixed that issue (missing consonants).

    Appeared an errant italic AND cursive font on some sites. Found a program "font-manager" which previews fonts. Found
    the .ttf file and moved it from /root/.fonts

    So all solved for now.
    Opera 12.16 build 1860 FreeBSD 10-STABLE.

  • An update to dejavu (fonts) made the consonants disappear en masse again.
    "pkg delete -f dejavu" fixed it

    So that appears to have been the actual problem from here, since I probably won't ever know more about the intricacies of font setup without an easy guide to follow, which I suspect due to different platforms of the fonts, won't ever occur.