Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • How can I stop Opera updating automatically? I had Opera 25 and now I've got Opera 26 but there was no warning. I like to choose when I upgrade myself but can't find any setting to change this. Is it still possible please?

    Since this update I also have the same problem with Adobe Reader as Greenskyline although I did find disabling it brought up the inbuilt Opera pdf reader but this is just another reason why I prefer to do my own updates when I'm ready and not when Opera thinks it should happen!

  • At present, the latest Opera versions are designed with automatic updating built in, no other user 'option' available. A user can manually rename the updater file to something else to block it, but then it will indeed block updating (manual or otherwise) unless/until renamed back to its original name. I share your concern about a variety of potential negative user impact associated with forced auto-updating, but it's the path Opera has currently chosen. The most likely reason is for Opera to be able to uniformly push security and bug-removal improvements, and to more easily and consistently track the related chromium/Blink-engine version release cycle.

  • Just create an outbound firewall rule to block autoupdate.exe (or whatever it's called). Disable the rule when you want Opera to update at a time of your choosing. Note that when the update is complete, you'll have to update the firewall rule as well because the update executable will now reside in a different folder.

  • Either way the problem stays:

    1. How to know you're being/have just been updated if your updater is up and running?
    2. How to know if there's an update available if your updater is disabled?
  • Thanks for your help guys. It looks like I'm going to revert back to Opera 12.17 as it's a lot faster even though I have problems with some sites. And Adobe Reader still works too.

  • You can try this

  • Deactivating auto-update is as simple as disabling the windows scheduler entry. easy to do from scheduled tasks in the control panel.

    OsX/Linux, it's probably in crontab